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P
This guide is for system managers who are responsible for managing
geographically dispersed servers.  It provides the information you need to manage
remote servers equipped with the DIGITAL Remote Server Manager (RSM).

The guide begins with a brief introduction to the DIGITAL Remote Server
Manager.  The chapters that follow describe the specifics of how to use your PC
as a management station: getting-started tasks, basic skills, advanced functions,
menus, files, and troubleshooting.

Another manual, the DIGITAL Remote Server Manager Hardware Installation
Guide, is also supplied.  This manual covers the installation process for the RSM
controller.  Please refer to that manual for more detailed information on installing
the RSM controller.

What You Need to Know
This guide assumes that you are  familiar with:

• The operational requirements of managing a network

• Unique requirements of monitoring and maintaining remote servers

• Planning, implementation, and troubleshooting communications
components such as telephone line/modem communications

• The Windows NT operating system and the System Configuration Utility
(SCU)
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RSM Key Features

Key Feature Description

Secure access to remote servers Access is limited by passwords and dialback to authorized
users

Alarm notifications Alarms can be set to occur on: out-of-range temperatures,
voltage values, temperature values, server status, and power
failures.

Scripted actions based on alarms An alarm may be set up to initiate a chain of events such as
dialing a pager or shutting down the system

Status Reports Information such as voltage, temperature, and power may be
exported to a database.

Event Log Contains historical status data which can be used for trending
and troubleshooting.

Remote Boot of Server Servers can be booted (upgrade BIOS or configure server)
from a diagnostic diskette loaded at the management station.

Download files Update files such as SCU configuration, CMOS setup, and
RSM files.
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Terminology
The following technical terms are used in this manual.

Term Definition

Remote Server Manager The remote server management solution from DIGITAL, also called
RSM..  RSM onsists of an integrated hardware & software product.

Management Station A Personal Computer (PC) with Windows NT V3.51 and RSM
software installed.  It enables a system manager to access remote
servers.

Remote Server Manager
Controller

The RSM hardware module installed in a remote server.  The
controller monitors the server even if the server is not functioning
provided that the remote power feature is installed.

The terms "Select" and "Choose" are used frequently in the procedures presented
in this guide to perform operations.  Both terms refer to specific mouse or
keyboard operations.

Term Definition

Select Move the mouse pointer to an item (icon, command, name, and so
on) and single-click the operational mouse button, or use the specified
set of keyboard keys.

Choose Move the mouse pointer to an item (icon, command, name, and so
on) and double-click the operational mouse button, or use the
specified set of keyboard keys.
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Keyboard Conventions
The following keyboard conventions are used by RSM.

To: Press These Keys

Scroll one window up or down PAGE UP, PAGE DOWN

Go to the beginning of the list CTRL, HOME

Go to the end of the list CTRL, END

Move focus left or right LEFT ARROW or RIGHT ARROW

Move focus one line up or down UP ARROW, DOWN ARROW

Move to next window CTRL, TAB

Move to previous window CTRL, SHIFT, TAB

Go to the next field DOWN ARROW or TAB

Go to the previous field UP ARROW, SHIFT, TAB

Go to the next Group CTRL+DOWN ARROW

Go to the previous Group CTRL+UP ARROW

Move the focus, up or down without affecting the
state of the previous line (to add or remove lines
from a selected set)

SHIFT+UP ARROW or SHIFT+DOWN ARROW

Toggle the state of the focus item SPACEBAR

Display Help F1

Display Help
(from a Console window)

CTRL+ALT+F1



Introduction �
Introduction

It can be very important to manage remote servers, especially if they are mission
critical.  DIGITAL Remote Server Manager (RSM) provides easy, quick, and
cost effective support for a remote server.  Local service technicians only need to
understand hardware installation and have a working knowledge of Microsoft's
Windows NT operating system.

RSM  manages your DIGITAL servers using RS232 connectivity connected either
directly or over a phone line using a modem.  The product consists of:

• EISA board and configuration software for the remote server

• Management station software for the local Microsoft Windows NT
desktop.

Using RSM you can take control of, or simply monitor, a server (even if it is not
on the network).  The server can be at a different geographic location or at the
same location.  The RSM controller in the remote server may be reachable even
though the network may be down.

You can also use RSM to save money,  time, and effort.  RSM centralizes
management of your remote servers.  As a result, you no longer require expensive
dispatch to, or expertise at, your remote sites.

RSM Solution Software
RSM  (part number QB-38EAA-SA) contains software media and documentation
for remotely managing a DIGITAL X86 processor-based server from a
management station running Microsoft’s Windows NT operating system.



RSM User’s Guide

2

RSM Features
The main features of RSM are:

• Remote server control

• Alarm notifications

• Security

• Remote access

• Remote maintenance

• Download files

These features are described in detail in the following sections.

Remote Server Control
RSM provides the following functions on a remote server:

• Resets1 a remote server as if the server's reset button was pressed.

• Boots a remote server as if either CTL+ALT+DELETE was entered or
the reset button was pressed.

• Powers on or powers off2 the remote server's power as if the server's
power switch was turned on or off.

Alarm Notifications
The RSM controller can operate independently of the server.  It monitors the
conditions previously specified and records any normal and/or out of range
readings.  It can send an alert to the management station or issue a page if the
server loses power, or if the server hardware stops functioning.

                                                  

1 A reset cable must be connected between the controller and the server’s  main logic board to reset a remote server.
2 The power On/Off function can only be done on servers that support it.  This function cannot be done on an XL server.
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Conditions which may be monitored are:

• Temperature and temperature change

• Power supply voltage levels

• Server mode

• Power-On Self-Test (POST) code

• Number of keystrokes since the last reset

An event or an alert occurs when a server condition exceeds a limit defined in the
Events file.  When an event occurs, RSM may record the server’s condition in
non-volatile memory for later recording to the management station server log. It
may also send an alert, to the management station or to a pager.  The events file
can be customized for the server environment, or the default file can be used.

Security
RSM provides user security to ensure that only authorized personnel can access
its capabilities. RSM provides its own user security options as an addition to the
standard Windows NT security.

Windows NT Security

RSM uses Windows NT security as the foundation to its security.  Windows NT
requires a password to log in.  Only authorized personnel should have a Windows
NT account on a management station.  The security of a management station and
access to managed servers depends on secure password administration.

RSM Security

RSM provides system managers with the choice of implementing or not
implementing RSM security. These options are No security and User security.

The No security option allows full access to the remote servers from the
management station.  This eases setup and learning how to use RSM.  DIGITAL
recommends that you implement user security once you feel comfortable using
RSM to manage servers.
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With the User security option, users are defined and a security file is created
which is sent to the remote server.   A User is defined as being a member of a
group, each of which has different privileges. The groups are User, Super User,
and Administrator groups (refer to Chapter 6, Files, for a detailed explanation of
the groups). These groups are placed into a security file which is transferred to the
server in encrypted form.

Another security feature is the Dial-back in which an RSM script can specify that
the remote server hangs up and dials-back a telephone number associated with a
management station. This would ensure that remote server access is available only
to authorized management stations.

Remote Access
If the remote server has a VGA console with a keyboard and monitor, you can use
your management station as a remote console.  Remote access to the Server’s
VGA Console and Keyboard allows the management station to appear as if its
monitor and keyboard are connected to the remote server.

To use the management station as a remote console, the server must have a VGA
frame buffer that is readable from the EISA bus. The VGA remote console works
when the server is in TEXT MODE ONLYgraphic modes are not supported.  If
the server is configured with a PCI-based on-board VGA video controller, an ISA
video controller  (part number FR-PCXAG-BC) is required for the remote
console.

Remote Maintenance
Remote maintenance can be performed through the management station’s diskette
drives.  The types of maintenance are as follows:

• Boot the server from a diagnostic diskette in the management station

• Use a diskette or a diskette-image file on the management station as a
server diskette

Diagnostics could also be simultaneously booted on multiple remote servers using
a diskette image file.
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File Transfers
RSM allows for special file transfers between the management station and the
remote server.  These files are: CMOS setup, EISA configuration, RSM
firmware, Extended BIOS, server keystroke log, and customized RSM files
(events, macros, scripts, and security).

Remote Server Manager Kits
There are various kits available for the RSM.  These are detailed in the following
sections.

DIGITAL Remote Server Manager Hardware Kit (FR-PCDSC-xx)

The RSM hardware kit consists of an EISA bus controller installed in a remote
server.  The controller has a serial communications port.

A modem or RS232 direct cable must also be connected to the management
station's serial communication port.  Additional hardware accessories include:
keyboard jumper cable, data cable, power supply, and power cord.

DIGITAL Remote Server Manager System Kit (FR-PCDSM-xx)

The RSM System Kit consists of both the RSM Hardware Kit Configuration
software and the DIGITAL Remote Server Management Station Software.

Cable Kit (FR-PCXCK-xx)

The Cable Kit consists of a platform-specific cable that connects the management
station EISA module to the remote  server’s main logic board. This cable is used
to reset the server and to power the server on or off.

Documentation
The following documents are shipped with RSM:

• DIGITAL Remote Server Manager Hardware Installation Guide

• DIGITAL Remote Server Management Station Software User's Guide
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Optional Remote Server Manager Products
Modem/Multiplexor Support

DIGITAL has tested and verified specific products such as modems and
multiplexors for interoperability, performance, and ease of use with RSM .

NOTE: DIGITAL provides a modem script file for a select number of modems.  If
the modem you are using is not one of the supported modems, it will need
to be customized. Refer to Appendix A for a list of the tested and verified
modems and multiplexors and their authorized resellers.

Hardware and Software Requirements :
Check that your management station PC meets the minimum hardware and
software requirements summarized in the following paragraphs before you install
RSM.

The minimum management station requirements to use RSM are:

• Microsoft Windows NT Version 3.51
• Intel 486, Pentium or Pentium Pro PC
• Hard disk with 4MB of available space (20 MB recommended)
• 16 MB Memory (32 MB recommended)
• 3.5-inch high-density (1.44 MB) disk drive
• SVGA video adapter
• A buffered serial port with a 16550 UART chip equipped with a supported

modem (refer to Appendix A)

DIGITAL Support and Warranty
Refer to the separate warranty information that comes with RSM for detailed
information on DIGITAL Remote Server Management software warranty.  This
warranty can be increased with support packages available from DIGITAL
Multivendor Customer Services (MCS).
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Getting Started  �
This chapter describes how to set up and configure the RSM hardware and
software components. The RSM setup tasks are:

1. Install the management station’s modem

2. Install the remote server’s modem.  Either pre-configure the modem on the
remote server or allow the RSM controller (on start-up3) to send a pre-defined
string to the modem that provides an initial configuration4

3. Install the management station’s multiplexor (optional)

4. Install the RSM controller into the remote server

5. Load the RSM software in the management station

6. Define the communications ports to be used on the management station

7. Verify the port settings

8. Start the RSM application

9. Configure the first server

10. Connect to the server

11. Exit the application (optional)

The following subsections discuss each of the previous steps.

To make the startup as easy as possible, do the steps in the order listed above.

                                                  

3 Turn on the modem first, then the RSM controller.
4 Refer to the RSM  Hardware Installation Guide for more information
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Installing a Modem into the Management Station
DIGITAL recommends installing the modem to a serial communications port on
the management station as a first step.  Refer to the modem documentation to
install the modem and to Appendix A, Communication Options, for information
about the recommended modems.

DIGITAL provides the initialization commands for a select group of modems in
the default Macros and Scripts files, which are: default.mcr, default scr,
srvm.mcr, and srvm.scr. The default.xxx files are used for the modem on the
management station while the files srvm.xxx are used for the modem on the remote
server. The svrm.xxx files should be downloaded to your remote server.

If you are using modems other than those listed in the default files, refer to your
modem documentation for the specific modem initialization commands.  Insert the
appropriate commands into the two default files before downloading the files.

Use the following guidelines to set up a new management station modem (the
guidelines may also be used to pre-configure a remote server modem):

• 8-bit asynchronous communications with no parity

• Auto Answer On

• Hardware Flow Control (RTS/CTS)

• Echo off

• CD and DTR follow standard RS232

• Verbal Result Codes

• DTE to DCE

• Speed at 38,4000 bps
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Installing a Modem into the Remote Server
Refer to the Remote Server Manager Hardware Installation Guide for
instructions on how to connect the modem to the RSM controller and to the
modem documentation for instructions on how to install the modem.  Appendix A,
Communication Options, contains information about the recommended modems.

Initialization commands for select modems are in the srvm.mcr, and srvm.scr
files. These files are loaded onto the management station during the RSM
software install and may then be downloaded to the remote server.

Installing a Multiplexor
Multiplexors are installed to provide more communications ports on the
management station.  This allows a “connect” to more remote servers at the same
time while having ports available to receive alerts.

Refer to the multiplexor documentation to install a multiplexor on a management
station.

Configuring the RSM Controller
Refer to the Remote Server Manager Hardware Installation Guide for the
instructions for installing the RSM controller.

A configuration diskette containing the system configuration file for the RSM
controller is supplied with the kit. When running the System Configuration Utility,
select the default memory address unless there is a known conflict.  No IRQ is
required.

NOTE: The modem installed in the remote server is initialized by the RSM
controller.  Therefore, the power should be turned ON in the following
order: modem, RSM controller, and server.  If the modem settings have
been saved in the NVRAM, this sequence does not have to followed.

DIGITAL recommends storing the modem settings in the modem’s
NVRAM. Details on doing this are supplied in the Release Notes.
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Installing RSM Software on the Management Station
1. Insert Setup disk # 1 into the appropriate high-density diskette drive (usually

drive A) and run A:\setup.exe.

2. During the setup, RSM asks you to confirm the default directory name or to
enter a new name.

During normal operations, log files are created (<server name>.log) in the
default directory.  The amount of disk space needed for server files will vary
depending on the number of servers and the size of the server log files.  The
size of the log files will depend on the types of events that are logged. If
events are defined so that they occur frequently, and if you do not regularly
delete server log files, the size of the server log files will grow faster than if
events are defined so that they occur only when there is an abnormal or
emergency situation.

3. Select OK or press [Enter] after Setup successfully completes. Setup
redisplays the Program Manager window and creates a new group window
that contains the Remote Server Management console icon.  In addition, Setup
adds the Port Manager icon to the Startup window so that it will start
automatically when you log onto your management station.

4. At the end of the installation, you are given the option of reading the
“Readme” file. This file contains information that is not covered in this
manual.

Changing the RSM working directory

You may want to change the directory that is used to transfer files.  This is done
by changing the RSM working directory.

1. Select the RSM icon from the Program Manager window.

2. Select File from the menu bar. The file pull-down menu displays.

3. Select Properties in the File pull-down menu (or press the ALT+F+P keys).
The Program Item Properties dialog box displays.
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4. Type the name of the directory that has the transferable files, and any new
files.  This is RSM's working directory.

5. Select OK or press Enter.

Defining the Communications Port on the
Management Station

You must specify the serial port(s) used by the RSM on the  management
stationfor RSM to work correctly.

Defining the communications port on the management station may be performed
in either one of two ways:

• Using Port Manager

• Using a rs_pm.ini file

Using Port Manager

1. Start the Port Manager’s Program Item Properties dialog box.

2. Enter the port argument on the command line:

port=[modem_type]:options:[server_name]
Refer to the port arguments table that follows for more information.

Using the rs_pm.ini file

1. Edit the file called rs_pm.ini file located in the RSM default directory.

2. Enter the section name, [Ports], (including left and right brackets) on the first
line of the rs_pm.ini file.

3. Enter a port argument line for each RSM port. The correct Port Argument
syntax is:

port=[modem_type]:options:[server_name]
Refer to the port arguments table that follows for more information.
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Port Argument Description

Port RSM port:  COM1, COM2, COM3,  …

Modem_type Must match the setup entry in the default.mcr file. Leave blank if you connect
directly to the serial line using a null modem cable rather than a modem.

Options Port options*:  answer (a), originate (o), direct (d), log(l)5

Server Name6 Server name for a server when using a null modem cable for a direct connection.

Examples

Command Description

com2=zoom:oa Port argument for a Zoom modem that can originate and answer calls

com3=:d:harvard Port argument for a direct connection to a server named harvard using a
null modem cable with carrier detect present.

Verifying Port Settings on the Management Station
The communications port used by the RSM must have the FIFO option activated.
If the FIFO option is not activated, heavy traffic on a communications line may
cause the connection to abort or to hang.

Verifying that the FIFO setting is activated

1. Select the Ports icon from the Windows NT Control menu.

2. Select the assigned communications ports used by the RSM from the Ports
dialog box.

3. Select "Settings" from the Ports dialog box.

4. Select "Advanced" from the Settings dialog box.

5. Verify that an X displays in the FIFO check box.  If not, select the check box.

                                                  

5 Use  the log option only for debugging purposes. This creates a file that can be analyzed by support personnel.
6 Case sensitive



Getting Started

13

Starting RSM on the Management Station
If the Port Manager is not running, then alerts may not be received by the
management station (Refer to the NOTES at the end of this section).

Starting RSM on a management station

1. Choose the RSM group icon from the Windows NT Program Manager.  The
RSM group window displays.

2. Choose the RSM icon. The RSM window displays.

3. Select the Remote Server Management console icon.  If the Port Manager is
not operational, the RSM executable will attempt to start it.

4. The first time you start up a management station, or any time RSM cannot
find any servers, a dialog box displays. Select OK or press Enter to continue
and the Select window is  displayed.

Refer to the next section for defining a remote server.
If the Port Manager has difficulty setting up the modem or if a port connection
fails, the name of the specific COM port that failed displays as follows:

Link Manager on port Com1 has terminated

RSM will not use this COM port again until you restart the Port Manager.

NOTES: DIGITAL recommends that you keep the Port Manager running, especially
if alerts are being sent to the management station. If the controller places a
call to a management station and the call does not complete for any reason
(the PC is off or the telephone is currently in use), the management station
does not receive that alert notification.

You can compensate for this problem by duplicating the alert condition as
a server log entry so that   the entry is added to the server log when a
connection is established with the server.  Event actions may also be
defined to redial multiple times or dial multiple management station ports.
If the management station has multiple modem ports, you can retry using
alternative telephone numbers.  Refer to Chapter 6, Files, for more
information on defining events.
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Defining the Remote Server
Once RSM is started, the Select window is displayed.  This window is shown
below.  The Select window displays basic information about each server.  If this is
the first time RSM is being used, the Select window lists only a default server,
“server_1”.

At a minimum, defining a server consists of specifying the name of the server in
the Server Names and Attributes window and a telephone number in the
Connection Actions window, then saving the information.
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Adding a server

1. Select the “setup” button at the bottom of the page. The Setup window
displays.

2. In the Server Names & Attributes window, enter a name for the server in the
Server Name field.  Refer to chapter 4 for more information on each of the
fields.

3. In the Connections Actions window, select the new action pull down menu.
Select the telephone number followed by the include or script options.  Refer
to the following display.
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4. Save the information on the server by selecting the “Save” button. The
information is saved to the file <server name>.sdf.  Continue with the next
section, “Making the Connection to the Server.”

Making the connection to the server

1. At the Select window, highlight the remote server and then click on the
“Control” button. The Control window displays.  The window is “dimmed
out” until the connection has completed. Once the connection is made, the
connection status information is filled in.
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NOTE: If the firmware on the RSM controller is an older version, the RSM
application automatically updates the firmware during the first connection.
The application transfers the new firmware files and once complete, the
remote server is rebootedas a result, the connection is lost.  When this
occurs, simply reconnect to the remote server.

2. At this point, the connection to the remote server has been made.  Next, files
should be transferred to the remote server defining the events. For more
information on transferring files, refer to Chapter 4, Advanced Functions.

Exiting from the Application
Exit from the RSM application by:

• Disconnecting from the remote server by selecting the “Disconnect”
button.

• Selecting File from the menu bar and Exit from the File pull-down menu.
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Basic Tasks�
This chapter briefly describes the DIGITAL Remote Server Manager (RSM)
windows and explains how to complete basic server management tasks.  Some of
these tasks may be done even when the server is not operational due to either a
server problem or because the server is powered off.

Window Size and Arrangement
The default sizes of the RSM windows are based on a recommended 17-inch
monitor with 1024 x 768 resolution.  On this monitor, you can simultaneously
view four different windows using the Windows Tile arrangement.  You can resize
all windows to suit various screen sizes and user preferences.  Resizing a window
does not change its font size, except management station windows.  Most
windows, such as the Select and Status windows, take advantage of the available
space on the parent window.

Cascade is the default window arrangement.

Main Windows
RSM uses the following six windows to perform specific remote server
management functions:

Window Function

Select Enables you to select specific servers.  You can open multiple Select windows, each
containing a subset of servers, by using filter options.

Setup Enables you to define a server, the connection parameters, and default file names for
the transfer.

Status Enables you to view the Server Event Log and status.

Control Enables you to access, monitor, maintain, and control a server.

Transfers Enables you to transfer server files and memory between the server and the
management station.  Server files refer to the files needed to access and control the
remote monitoring of the server, as well as to the server's configuration.

Console Enables you to monitor VGA console and to enter data from the management station
keyboard.
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Supporting Windows
RSM also uses the following windows and dialog boxes to support main windows:

Window or Dialog Box Supporting Task

Preferences Allows you to customize global application settings.

Event Definitions Allows you to select a variety of server conditions and define RSM's
response to those conditions.

Macro Definitions Allows you to define macros that consist of a series of actions to be
executed when an event occurs.  Macro definitions are also used to define
event actions or connection actions.

Script Definitions Modem scripts that Expect/Send definitions to make a connection.  A CHAT
script is sent to the modem.  This is a series of Expect and Send dialogs to
connect the management station to its modem. You can use a CHAT script
to connect your management station to a server.  The controller uses a
CHAT script for dial-back and to connect to a management station when an
alert is sent.

Security Definitions Enables users to specify user names, user groups, and passwords.

Viewing Servers in the Select Window
The Select window shown in the following illustration displays basic information
about each server.  Initially, the only server listed in the Select window is the
default server “server_1”.  Once a new server is defined and saved, it appears in
the Select window.

Current keyboard focus is visible as a dotted rectangle.  Current selections are
visible with color highlighting.  Use the scroll bar or the arrow keys to view all the
managed servers. Use the display and filter options to create multiple Select
windows with a subset of servers.



Basic Tasks

21

Selecting a Server
The first step in managing servers is to select one or more servers.  The Select
window makes it quick and easy to select and manage multiple servers
simultaneously.

Selecting or deselecting one or more servers

1. Move the mouse pointer to a server name on the Select window.

2. Refer to the following table and complete the specific operation.
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To Make This Selection Do This

Select one server. Single Click the mouse button

Add another server to a set of selected servers.  If the server is
already selected, remove it from the set of selected servers.

Press CTRL+Single Click the mouse button

Select all servers between the last one you selected and your
current selection.

Press SHIFT+Single Click the mouse button

Select all servers between the beginning and ending cursor
position.

Press SHIFT+Single Click the mouse button
and hold+Drag the mouse

If you select a server then change your mind Single Click on another server to deselect
that server and begin again.

Server Directory Window
The Server Directory window displays a summary of information about each
server.

The following table describes the fields in the Server Directory window.

Field Description

Server The server's unique name, also called the Short Name..

Alert The elapsed time that an alert has been waiting, in either hours and minutes or
number of days.  Field is blank if no alert is waiting.

Session The elapsed time of the current connection in either hours and minutes or number
of days .  If there is no connection, this field is blank. If a connection is in process,
the field displays “Pending.”

Last Contact   If connected, the time and date of the most recent connection.

If not connected and the RSM sent an alert during the last connection, the time
and date RSM sent the alert.

If not connected, displays the time and date the connection was closed.

Description The server’s long, descriptive name and information field.
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Setting up Servers with the Setup Window
You use the Setup window to enter basic information about the remote server,
such as its name and attributes, its connection parameters, and a default file name
for transfers.  You can also use the Setup window to make changes to existing
servers.

Once you save the server information, the server’s name is displayed in the Select
window.



RSM User's Guide

24

Adding a new server

1. Select Setup from the Select window. The Setup window displays.    

2. Enter the appropriate information in each field.  The following table explains
the fields of the Server Names and Attributes Window.  The sections that
follow explain the Connection Actions and Defaults for File Transfers
windows.

3. Select OK or press Enter.

Field Description

Server Name The unique server name for each remote server.  The server name can be up
to eight characters long and is used to associate any particular events and
alerts with the server. If you enter a duplicate server name, RSM displays an
error message.

Description The description is optional.  The description must be less than 64 characters.
If you enter a duplicate description RSM displays an error message.

Time Zone Time Zone indicates the remote server’s time zone.  The default is the
management station’s time zone.

System Type Choose the type of server being  managed.  The default server types are:

Intel Server —provides complete server functionality

XL Server 466—provides complete server functionality, except for cold boot.

Zone The field "Zone" is a user-defined Server Attribute Value that was entered in the
Preferences window. A user-defined value can be entered to facilitate remote
server management and operations.  If an attribute is not defined (in the
Preferences window), this field is blank.  A Server Attribute Value can contain a
maximum of 30 characters.

Entering Server Information

Enter a unique server name in the Server Names and Attributes window and enter
connection instructions  in the Connection Actions window.  Entering information
in the Default File Names for Transfers window is optional. RSM is case-
sensitive, so you must enter the default names in lower case.  When you enter
information in this window, you can define default file names for any management
station transfer files, or any server files.
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Adding Server Information into the Server Names Window

1. Select <required> in the Short Name text box and enter a unique name.

2. Select <no default> in the Long Name text box and enter a descriptive name.
You may leave this field blank.

3. Select "Time Zone".  Select the server's time zone, if the server is not in the
same time zone as the management station.

NOTE: If there is a problem keeping current time between the server and
management station in different time zones when running on a Windows
NT system, use the standard zone instead of the Windows NT expanded
time zone names (for example: Lima, Peru, vs. Eastern time, use Eastern).

4. Select the System type.  The default is Intel Server.

5. Choose a Server Attribute Value text box. Enter a Server Attribute Value of
up to 30 characters.  You may leave this field blank.  A Server Attribute
Name displays if previously entered on the Preferences window.

The server name and any description you entered both display in the Select
window.  The server name displays in a number of RSM windows identifying that
server with its associated management information.

Connection Actions Window
The Connection Actions window displays a list of actions that may be used to
connect the management station to a remote server. The connection window is
blank when doing a direct connect to a new server.

Connection actions are an ordered list of actions that the RSM uses to connect to
a remote server.  You can enter the connection actions in the Connection Actions
window and refer to  the RSM default Macros and Scripts file entries when using
Include or Script Actions respectively.



RSM User's Guide

26

NOTE: Refer to the default Macros file (default.mcr), and the default Script file
(default.scr), in Appendix B for examples of the Modem connection
information.

Entering Connection Information
RSM provides the following connection actions:

Connection Action Description

Include Executes a macro from the default Macros file (default.mcr) that defines a
set of connection actions.  Enter a macro name to identify the macro.

Port Lists the ports supported by RSM (COM1 (the default) – COMx). The Port
pull-down menu lists the ports that RSM can use and also lists Auto.  Auto
allows RSM to let the Port Manager choose  the next available originating
port.

Retry Automatically attempts to connect a failed connection for the number of
iterations specified.

Script Adds a line in a script file consisting of a dialog of messages to send and
expected responses.  Enter a name to identify the line, plus an optional file
name.

Speed Displays the serial port baud rates for modem to port connection. Values are:
300, 1200, 2400, 4800, 9600, 14400, 19200, 38400, and 57600.

Telephone The telephone number, plus optional special characters.  In most cases, only
the telephone number displays.  Special characters can be included to
specify extra features, such as pauses, selecting pulse or tone dialing.  The
telephone number must include all digits needed to reach the server through
a telephone line.
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Entering a connection action

1. Select <new action> for the Connection Actions pull-down menu display.
Select a connection action.

2. Select a value from the Connection Action pull-down menu or enter the
appropriate information and press Tab.

Inserting an additional connection action into an existing connection actions list

1. Select the line where you want to place the new connection action name.

2. Select the Insert button.  The selected line moves down one line.

3. Enter the new Connection Action name.
Deleting a connection action

1. Select the connection action name you want to delete.

2. Select the Delete button.
Reordering the connection actions

1. Select a Connection Action.

2. Select either the up arrow or the down arrow.  The up arrow moves the
selected item one line toward the top of the list each time you select it.  The
down arrow moves the selected item one line toward the bottom of the list.

3. Place the Connection Action where you want it on the list.

Default File Names for Transfers
The Transfer window Default File Names field is used  to enter names for
transferable configuration files and memory.

Entering file names in this window is optional.  You can use the Setup window to
define default file names and gain efficiency when updating multiple servers if you
regularly transfer the same files or memory.  If files names are unknown,, leave
this window blank until you plan to use it or know the default file names to
specify. Any file name you enter as part of a transfer in the Transfers window also
displays in this window.
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NOTE: This information is stored as files on the management station, but on the
servers, it is stored in memory location.  You can transfer this information
from the files on the management station to the appropriate server memory
locations, or from the server’s memory (except for the keystrokes) to files
on the management station.

Defining a default file name

Scroll through the list to find a file you want to transfer.  You can use the RSM
default name or enter a different file name.  Refer to Chapter 4, Advanced
Functions, for a description of these files.

1. Select a file name.

2. Enter a file name, or select the arrow to the right.  The Enter file name
browser window displays.

3.  Select a file name from the File Name window and select OK.  The file name
displays in the Default File Names for Transfers window.

Saving Server Information
Save any information you entered or changed on the Setup window so that RSM
can use it to access and manage the server.

The three Setup buttons located at the bottom of the Setup window enable you to
save or discard changes and close the Setup window.
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Save —Saves changes made to Setup fields.  If the server's Short Name already
exists, an error message displays and you must enter a unique Short Name
before you can save the Setup information.  If the server's Long Name already
exists, an informational message appears for confirmation, but you can still save
the setup information.  Save is available if you made any changes.

Cancel—Closes the Setup window.  If you have made any changes, RSM asks
whether you want to save or discard the changes before closing the Setup
window.  Cancel is always available.

OK—Saves changes made to setup fields and closes the Setup window.  OK is
always available.

Saving the server information

• Select OK if you did not change any server information

• Select Save to save changes, then select OK.

Defining and Changing Multiple Servers
You can add new servers and change information about existing servers.

Adding additional servers or changing the definition of existing servers

1. Select a server name on a Select window.

2. Select Setup from the Select window.  Move the mouse pointer to the Setup
button and click, or select Function from the menu bar and select Edit Setup
from the Function pull-down menu.

Using the Setup Buttons
The four setup buttons in the Another Setup window enable you to define multiple
servers quickly and easily.  The New Setup button lets you define a new server.
Copy, Next, and Previous let you view and change the information contained in
the setup fields for servers with any of the same or similar parameters.

New—Clears all fields in the current Setup window so that you can enter
information to define a new server.
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Copy—Copies all fields except for Short Name in the current Setup window
and creates a new Setup window.  Copy is a quick way to set up multiple
servers and define identical default file names for transfers between your
management station and multiple servers.  It is available when there is
information in the Setup window.

Next—Opens a Setup window for the next selected server.  Next is available
when you have selected multiple servers in the Setup window and there is
another server in the selected set that follows.

Previous—Opens a Setup window for the previously selected server.  Previous
is available when you have selected multiple servers and there is another server
in the selected set that precedes the current server.

Transferring Controller Files to a Server
You need to set up the controller before you can use RSM to access and manage
remote servers.  This includes customizing the controller files for your specific
server and server environment, then transferring the files to the RSM controller.
Customize these files by defining the server conditions that RSM monitors: events,
macros, and connection dialogs (scripts).  Move the files through the Transfers
window.

RSM provides examples of these files in your RSM directory.  Their file names
are srvm or examplex (x signifies a number, starting with 1) plus the file extension
(.evt, .mcr, or .scr).  Refer to Appendix B, File Examples, for file examples. Edit
the files using RSM's customized editors or any text editor.  Refer to Chapter 6,
Files, for more information on viewing and editing files.  Refer to Chapter 4,
Advanced Functions, for information on how to transfer files.
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Exiting Remote Server Manager
Exiting RSM

1. Select File from the menu bar.  Select Exit from the File pull-down menu.

2. A dialog box displays asking you if you want to save any changes before
closing any window with unsaved information.

3. RSM saves the current window arrangement, if you activate the Save
Window Layout option.  Refer to Chapter 5, Menus and Preferences, for
information on user preferences and RSM defaults.

Using Server Sort and Filter Options
You can display all the servers you are managing in a preferred Sort order on the
Select window.  You can limit the number of servers that display with a filter.
The Sort options are available on the Select window Options menu; the filter
option is in the Select window below the server directory.

Using Server Sort Options
You can sort servers in ascending or descending alphabetical order by name, last
connect time, connect time and alert pending.  The default is to sort by name.  The
current option has a check mark before the option.

Sorting servers in a different order

1. Choose Options from the RSM windows.  The Options pull-down menu
displays.

2. Select the specific Sort by… command from the Options pull-down menu that
meets your needs.

Using the Server Filter Option
Choose specific servers to display by using the Filters window, which appears in
the Select window below the Server directory.  The filters use defined Server
Attributes Names and Values to determine whether or not to display a server.
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Before using the Filter option, complete the following procedure:

1. Enter the Server Attribute Names in the Preferences window.

2. Enter the Server Attribute Values in the Setup window.
Refer to Chapter 5, Menus and Preferences, for defining Server Attribute Names.
Refer to Chapter 2, Getting Started, for entering Server Attribute Values.

Selecting servers with specific server attributes:

1. Select <new filter> in the Filters window.

2. Select a Server Attribute Name.

3. Select Test on the Filters menu bar.  The Test pull-down menu displays.

NOTE: Based on the specific options for an event, not all of these symbols will
display.  Only those symbols that are applicable to the event will display.

Ranges can be given for alphanumeric or numeric values.

Test Description

== Equal

!= Not equal

[ ] Inside a range [1,3]

] [ Outside a range ] 1,5 [

> Greater than (2 > 1)

< Less than (1 < 2)
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− If you are testing for equality (default test), proceed to step 4.

− If you are doing any other tests, choose Equality. Select the
scroll on the right side of the field and select one of the other test
alternatives.

4. Select <none> in the Value field and enter a Server Attribute Value.

5. Select Keep/Drop from the Filters menu bar. The Keep/Drop pull-down menu
displays with the default (Keep).

 To keep the attribute, proceed to step 6.
 To remove a server, select the scroll arrow on the right side of the

Keep/Drop field.  The Keep/Drop pull-down menu displays.  Select
Drop.

6. Select the X displayed in the Enable field.  The X (default) toggles to a check
mark.  The check mark activates the filter criteria, enabling you to do a filter
operation, and includes the criteria in the filter operation.

Inserting, Deleting, and Reordering Server Attribute Criteria
Inserting an additional server attribute criterion into an existing filter

1. Select the attribute name where you want to insert the additional criterion.

2. Select Insert.  The selected attribute name moves down one line, leaving a
blank line.

3. Enter the additional server attribute criterion on the blank line.
Deleting a server attribute criterion

1. Select a server attribute criterion name from the list.

2. Select Delete.
Reordering server attribute criteria

1. Select a server attribute criterion name from the list.

2. Select either the up arrow button or the down arrow button.  The selected
criterion will move one line up each time you select the up arrow button.  It
moves one line down each time you select the down arrow button.

3. Move the server attribute to a new location on the list.
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Connecting to a Server
You can connect to a remote server through a serial connection when you activate
the Connect button in the server’s control window.

NOTES: When making a connection, RSM checks the RSM controller board
installed in the remote server.  If either the board's firmware version and
revision number or its EBIOS version is older than RSM (the installed
version) requires, a dialog box displays.  You have the option to upgrade
the board's firmware and/or EBIOS from the management station's
executable directory through this box.  In some instances, the firmware
must be upgraded before continuing.

Choose OK to start the upgrade process.  RSM downloads and reboots the
remote board's firmware, reconnects the board to the server, and downloads
the new EBIOS, if needed.  Choose Cancel to disconnect the server.

If you choose to upgrade, be sure to complete the operation before cycling
power on the server.  If power is lost, the board may be in an unusable state
when repowered.  Should the connection fail during an upgrade operation,
it can be completed upon a subsequent connection as long as power outage
on the board has not occurred.

Connecting to a server

1. Select a server name from the Server Directory.

2. Select Control.   The Control window for that server displays.

3. Select Connect from the Control window.

NOTE: Do not double-click the Connect button.  The dialog button changes to
Abort during the connection process, and the second click aborts the
connection process.

You can also connect to a remote server by opening the Functions pull-down
menu and selecting Connect, or by selecting the Control button on the Status
window.  Both change to Disconnect after the connection is made, and can be used
to disconnect the connection.
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Connection Status
The Connection Status window lists scrollable messages during the connection
process.

Although you cannot modify these messages, you can select and copy them to the
clipboard for later use.  RSM:

• Displays  the "Connection successfully established" message after a
successful connection.

• Displays the "Connection failed due to: xxx" message after a connection
fails.  "xxx" lists the reason for the failure.  Most failures result from a
time-out or carrier failure.  Just before a failure message displays, a
statement from the Connection script displays explaining where the
connection failed.

• Adds "Connected" or "Not Connected" to the server name in the Setup,
Status, Control, Console, and Transfers windows title bar.

Connecting to Multiple Servers
To connect to multiple servers, repeat the process to a server or select multiple
servers before selecting Control.
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RSM does not limit the number of servers to which you can connect.  The
management station's CPU and resources do impose a limit on the maximum
number of simultaneous connections.  Management station resources that limit
telephone connections include the number of telephone lines, RSM’s serial ports
and/or multiplexors, and modems.  All resources are dedicated to RSM when a
connection is active or if the phone line is being used for callback when an event
occurs.

RSM waits for an available serial port if one is not immediately available.  This is
indicated by the word "Pending", which displays in the Select window's Session
column.

Monitoring Server Status
You can monitor server status through controls located on the Status window.
The Status window displays a server log, environmental sensors, and system
status.  The title bar displays the name of the server with its connection status.
You can access the Status window through the View Status button located on the
Select window or by using the Window option located on the Select menu bar.

The values shown in the Status window reflect the server status as of the last
update.  The controller checks the server's internal and external conditions every
five seconds.  RSM updates the Status window when:

• The management station connects to a server

• Information changes in the Environment Sensors and the Server System
Status windows, if the management station is connected to the server

• The management station receives an alert

• You press the update button.
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Monitoring server status

1. Select a server name.

2. Select Status, or double-click the server name.

TIP: A quick way to view status on several servers is to press SHIFT key and
select multiple servers.  Double-click the mouse with the pointer on the
servers.  This adds the servers to the set and opens a Status window for
each selected server.

Server Log
The Server Log keeps a history of various activities that occurred during a
connection. Log entries display in chronological order starting with the most
recent entry.  All log entries that existed prior to opening the Status window,
except alerts, display in black text; new log entries that occur while the Status
window is open display in blue text.  Alerts always display in red text.  An alert
displays in the server log when it arrives at the management station.
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To display fields that are not visible, such as Tag and Source, select the right
arrow on the horizontal scroll bar.

Time of Event Time and date the server log entry occurred.

Parameter An internal or external condition that the controller monitors.

Test Comparison between two values.  If two numbers are
compared, the result is consistent with standard math
sage. For example, -1V is greater than -12V.

Test Meaning

[] Inside

][ Outside

> Greater than

< Less than

Limit Value that was compared.

Value Actual value of the sensor at the time of the server log entry.

Tag A user-defined category that can be used to organize
log information in any way that facilitates effective
server management.

Source The source for the server log entry.  Currently, the controller event
 monitor generates all server log entries.
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Using Server Log Entries in Other Applications
You can copy, export, and print any part or all of the server log.  Use the Copy
command from the Edit pull-down menu and the Export and Print commands from
the File pull-down menu.  Refer to the Exporting and Printing Status section later
in this chapter for more information.

Environment Sensors
The Environment Sensors window on the Status window displays a server's status
at the time of the most recent update.  A green value indicates that the sensor is
within predefined limits.  A red value indicates that the sensor is outside these
limits.

Field Description

Temperature The default display is in Celsius. You can change the scale using the
Preferences command in the Options menu.  Refer to Chapter 5, Menus and
Preferences, for information on user preferences.

Temperature change: The controller monitors the average temperature during the last four hours by
sampling the temperature every five minutes.  The average is compared with
the current reading to get a positive or negative difference that displays in this
field and can also be used in an event definition.

Voltages:   +5V, +12V, -5V, -12V, 3.3V, and the controller's external power supply.
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Server System Status
The Server System Status window displays system status as follows.

The following table explains the fields in the Server System Status window.

Server System Status Description

Server Mode Displays the possible server modes in the Server Mode table
that follows this table.

POST (Power On Self Test)
Result

Displays a server-specific three-digit code.  00 indicates a
successful power-on self-test.  A failed self test is indicated by a
value that represents the reason for the failure.  Refer to your
server documentation for an explanation of the possible values.
This value is only reliable when the BIOS  POST test fails,
because some operating systems subsequently use the space
for other purposes.

Keyboard Status Displays all possible keyboard status values.

Keystrokes Displays the number of keystrokes since the last system reset.

Software Version The controller's software version is the number that precedes
the colon.  The numbers delimited by the colon represent (from
left to right):  the firmware Version: the EBIOS Version: the
Diagnostic Version: and the Keyboard Controller Version.
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Server Mode
The following table lists and describes the Server Mode options:

Server Mode Description

Init The server controller board firmware has been rebooted.  This is rarely
displayed in the Server System Status window.

Held RSM prevents the server from booting.  This allows diagnostics and
configuration to be done without an operating system running on the
server.

BIOS BIOS operating mode.  RSM intercepts and emulates BIOS calls and
recognizes a change to the BIOS mode when the BIOS executes the
RSM controller board's EBIOS (after it is reset).

Run Run displays instead of BIOS if the RSM's Extended BIOS (EBIOS) is
disabled.

Reset The server has been reset.  This occurs when the power comes on,
you press the reset button, and (depending on the server’s operating
system) when you press the server's CTL+ALT+DELETE keys.

Power Off The server's power has been turned off.

NOTE:   The Server Mode sequence during a normal boot is:  RESET, and then
BIOS.  Some operating systems change from BIOS mode to another Server
Mode.  RSM cannot detect this mode change.  As a result, the Status
window displays Server Mode as BIOS, although the server has actually
exited from BIOS to an OS running state.
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Keyboard Status
The following table lists and describes the Keyboard Status options:

Keyboard Status Description

Normal The server’s keyboard cable is plugged into the controller,
the server’s power is on, and the keyboard is operating
normally.

No System Response The server’s keyboard cable is plugged into the controller,
the server’s power is on, but the keyboard is not responding
to RSM.

Controller Failure The RSM controller has failed.

Keyboard Cable Unplugged The keyboard cable is unplugged.

System Cable Unplugged The system cable is unplugged.

Remote Console A Remote Console window is open.  Keystroke input can
be entered only from the management station.

Power Off The server’s power is off.

Updating Status
Updating status in a Status window

1. Select Update from the Server Log window.  The Update button changes to
Abort during the update.

2. Select Abort if you want to stop the update before it completes.
The message, "Log upload: the controller's log is empty" displays if there are no
new server log entries to transfer. This message displays only once per session,
even if you update the Status window several times and each time there are no
new server log entries for transfer.

Exporting and Printing Status
You can write server status to a file or print it using the Export and Print
commands in the File pull-down menu.  The Export command places server status
into a file. The Print command prints status information for the server.  The
Export and Print dialog boxes have check boxes for exporting or printing
environment sensor values and/or log entries.  You can also export or print a
specific log entry or multiple log entries.
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Printing server status

1. Select File from the menu bar.  Move the mouse pointer to File and click
once, or press ALT + F.  The File pull-down menu displays.

2. Select the Print command in the File pull-down menu. The Print dialog box
displays.

3. Set or clear the Print Sensor Data and Print Log Entries check boxes.

4. Select OK on the Print dialog box.
Writing server status to a file

1. Select File from the menu bar.  The File pull-down menu displays.

2. Select Export on the pull-down menu.  The Export dialog box displays.

3. Set or clear the Export Sensor Data and Export Log Entries check boxes.

4. Select OK on the Export dialog box.

5. Enter the file name in the File Name text box or choose a file name on the File
dialog box.  RSM prompts for a file name using the server name.  The
extension ".txt" is the default.

6. Select OK on the File dialog box.

7. Select OK on the Confirmation dialog box.
Prining or Exporting Log Entries to a file

The status information includes the server name and description, if applicable,
followed by the information that you request.  To select a complete list, press
CTRL + A.

1. Select a log entry or a series of log entries.

2. Select File from the menu bar.  The File pull-down menu displays.
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3. Select Export or Print from the File pull-down menu.  The appropriate dialog
box displays.

4. Set or clear the Print or Export Sensor Data and Log Entries check boxes.

5. Select OK on the Print or Export dialog box.  The "Export Server Status and
Log To:" dialog box displays.

6. Enter the file name in the File Name text box or choose a file name on the File
dialog box.

7. Select OK.
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Switching to a Different Window
You can open a new RSM window using Window.  The Window pull-down menu
lists the names of all servers with currently open windows.

Making a new or different RSM window active

1. Select a server name from the Window menu.

2. Select Window from RSM menu bar.  The Window pull-down menu displays.

3. Select the RSM window you want to make active and visible.
Displaying all active server windows

1. Select a server window.

2. Select Window from the menu bar.  The Window pull-down menu displays.

3.  Select Tile Server from the Window pull-down menu.  The active server
windows display.

Closing all active server windows

1. Select a server window.

2. Select Window from the menu bar.  The Window pull-down menu displays.

3.  Select Close Server from the Window pull-down menu.  All server windows
will close.  Close Server will not disconnect an established server connection,
unless "Disconnect on Control Close" preference option is in use.

Removing a Server
You can remove a server from the list of supported servers in the Select window.
Removing the server closes any active windows for that server and deletes any
associated files.

Removing a server

1. Select Functions from the menu bar.  The Functions pull-down menu displays.

2. Select "Select Servers".  The Select window displays.
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3. Select a server or multiple servers from the Server Directory.

4. Select Functions from the RSM menu bar.  The Functions pull-down menu
displays.

5. Select Remove.  A Notification confirmation box displays.

6. Select Yes on the Notification dialog box.

Receiving Alerts
The ability to monitor and control a remote server on an as-needed basis meets
most operational needs.  However, there are a few abnormal or special conditions
that must be reported immediately.  RSM provides alerts for these conditions. The
controller senses the condition and immediately sends a notice to a management
station or a pager.  Since the controller checks the condition of the server in five
second intervals, and it takes only a few seconds to send a message, notification of
this type of problem is almost instantaneous.

The alert displays in the Port Manager window.  The Port Manager window
immediately displays on top of any other open windows and sounds a beep.  The
elapsed time that an alert has been waiting displays in the Select window.
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You can define specific actions that allow you to use an existing telephone
connection from the management station to the remote server, if a connection
exists.  If a connection between both does not exist, the action is sent to a log file
if one is set up; otherwise the alert is lost.

NOTES: DIGITAL recommends that you keep the Port Manager running, especially
if you are sending alerts to the management station.  If the controller
places a call to a management station and the call does not complete (for
instance, if the PC is off or the telephone is currently in use), you will not
receive the alert notification. You can compensate for this by duplicating
the alert condition as a server log entry.

RSM adds this alert/log entry to the server log as one of the conditions that
caused the alert.  You can also define event actions to redial multiple
times. If your management station has multiple modem ports, you can retry
using alternative telephone numbers.  Refer to Chapter 6, Files, for more
information.

Disconnecting from a Server
You can disconnect a server using the Functions pull-down menu or the
Disconnect button on the Control window.

Disconnecting a server

1. Select Functions from the menu bar.  The Functions pull-down menu displays.

2.  Select Disconnect from the Functions pull-down menu or select Disconnect on
the Control window.
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Advanced Functions  �
This chapter explains how to use Remote Server Manager (RSM) for advanced
remote server management functions such as:

• Controlling server functions (power cycles, booting)

• Setting the correct time

• Transferring configuration files and memory

• Using the Remote Diskette feature

• Using your management station as a remote console

Controlling Server Functions
The Control window provides the remote server control functions, such as turning
the server's power off and on, booting, and transferring configuration files and
memory.
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The title bar displays the connected server’s name and its connection status. The
Connection Status window lists various connection status messages.  The table
below lists the buttons for Boot Operations and Other Operations. The last row of
the window contains buttons for Disconnect (or Connect if the server is not
connected), Open Console, and Close.

Button Function

Power on Powers the remote server off or on.

Reset/Keys Resets the server or sends special key commands to the
remote server.

Release Releases the server from Held mode and sends special key
combinations to the server

Set  Diskette Sets the Remote Diskettes feature

Set Clock Sets the remote server and controller clocks.

Transfers Transfer configuration and memory files

Turning the Server's Power On and Off
Turning the server's power on or off

1. Select Power Off or Power On button from the Control window.  The Turn
Power On or Turn Power Off confirmation box displays.

2. Select OK.  If you turn the power on, you can choose to hold the server after
booting.  Refer to the section, Holding a Server, later in this chapter.



Advanced Functions

51

Resetting and Sending Special Key Combinations to
a Remote Server

The RSM’s ability to remotely reset a server or to send special key combinations
to the server depends on how the RSM software operates with the server's
hardware and software.  You reset a server or send key combinations from the
Reset/Keys dialog box, shown in the following figure.

The following table lists and explains the Reset/Keys dialog box options.

Option Function

Reset Equivalent to pressing the server's Reset button.

Cold Boot7 Equivalent to pressing the system controller Reset button.

Warm Boot Equivalent to pressing CTRL+ALT+DELETE on the server’s keyboard.  A server's
response depends on the server’s operating system.

Alt/Esc Equivalent to pressing ALT+ESCAPE on the server's keyboard.

Set EBIOS Addr This is an emergency feature.  If the EBIOS does not operate (for example BIOS
address conflict), a temporary EBIOS address can be set for the next reset.

Reset Firmware Reboots the controller’s firmware.  The Reset Firmware button enables you to
update a controller’s firmware remotely.  This is only done when you get a new
version of the firmware from DIGITAL or to help diagnose a firmware problem.

                                                  

7 Not supported on an XL server.
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Performing reset operations on a remote server

1. Select Reset/Keys.  The Reset/Keys dialog box displays.

2. Select a Reset option from the Reset/Keys dialog box

3. Verify that the Hold on Boot box is blank.

4. Select OK.

NOTE: Resetting the firmware disconnects the management station from the
remote server.

Holding a Server
RSM can hold a server during power on and boot operations. This is done to keep
the server's operating system from interfering during server maintenance.  It is a
requirement for some tasks, such as setting clocks and transferring an EISA
configuration, that the server be in Held mode.

The Hold on Boot check box is located on the Power On and the Reset/Keys
dialog boxes.  A blank check box indicates that the option is not active.  An X
indicates that the option is active. Deactivate this option if you want the operating
system to come up normally.

Putting a server in Held Mode after it is reset

1. Select Reset/Keys. The Reset/Keys dialog box displays.

2. Select one of the Server reset options from the Reset/Keys dialog box.

3. Verify that the Hold on Boot option is active by checking for an X in the Hold
on Boot check box.

4. Select OK.

Releasing the Server from Held Mode
 Select Release from the Control window to remove the server from Held mode
and allow it to finish booting and resume normal operations.
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NOTE: The only way you can change the server's mode when it is in Held mode is
to release or reset the server with the Hold on Boot box blank,  or to
physically reset the controller to its factory defaults (refer to the RSM
Hardware Installation Guide). Resetting a server at the remote site will not
prevent it from going into Held mode.

Alt/Esc
This command sends the Alt Escape combination to a remote  server.  This
sequence is helpful for Novell servers.

Setting the Extended BIOS (EBIOS) Address
This is an emergency feature that can be used if the RSM Extended BIOS
(EBIOS) does not operate.  This may occur if:

• The server’s NVRAM containing the system configuration is corrupt

• The RSM board was installed without running the System Configuration
Utility

• The RSM EBIOS address conflicts with an ISA card when running the
System Configuration Utility

• No EBIOS address has been assigned

• The EBIOS download had been previously aborted and the server has
been reset (a warning displays when you attempt to reset a server with a
corrupt EBIOS).

Setting the EBIOS Address

1. Select Set EBIOS Addr from the Reset/Keys window. The Extended BIOS
Address field displays.

2. Select the scroll arrow from the right side of the field.  A pull-down menu
with the associated EBIOS addresses displays.
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NOTE: Selecting Disable does not remove the current EBIOS address.  This
selection should be ignored.

3. Select an EBIOS address.  It displays in the EBIOS field.

4. Select OK.  A confirmation dialog box displays, verifying the new EBIOS
address setting.  Select OK.

5. Reset the server using a warm boot to make the address setting effective.

6. Either run the SCU via  remote diskette or download the saved contents of the
EISA configuration to make the setting permanent.

Setting the Controller Clock or the Server Clock
The RSM controller clock places a time-stamp on internal and external server
conditions.  It does this even when the server is not operating.  Use the Set Clock
dialog box to reset the controller clock or server clock. If the remote server and
the management station are in different time zones, the RSM controller converts
the server’s time to the management station’s local time.
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NOTE: The server must be in Held mode to set either the RSM controller’s clock
or the remote server's clock.

The management station local time displays in the Management Station Time
window.  The remote server local time displays on the Remote Server Times
window.  You cannot reset the Remote Server time.

Setting the remote server's clock

1. Select the Hold on Boot box on the Reset/Keys dialog box.  An X displays.

2. Select Set Clock. The Set Clock(s) dialog box displays.

3. Select the Sys (system clock) checkbox under the Set field to activate the
setting.  An X displays.

4. Select Set Remote from Local.

5. Select Cancel to return to the Control Window.
Setting the remote server's controller board clock

1. Select Reset from the Reset/Keys dialog box.  Verify that an X displays in the
Hold on Boot check box.

2. Select Set Clock from the Control window.  The Set Clocks(s) dialog box
displays.

3. Select Set for Ctlr (controller).  An X displays.
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4. Select Set Remote from Local.

5. Select Cancel to return to the Control Window.

Transferring Server Files and Memory
The Transfer window is used to transfer configuration files and RSM program
files and RSM program files from your management station to the remote server
and from the remote server to the management station.

NOTE: Configuration files refer to the files needed to access and control remote
server monitoring and configuration.

You must be connected to a remote server to make a transfer.  However, you can
enter file names in the Transfers window at any time.

The RSM file names default from the server Setup screen. You can modify the
default files or enter your own user-defined files and file names.

The following table describes the default server files and memory options.
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Server File or
Memory

File Name Description

Scripts srvm.scr Defines the communication dialog used to make a connection
between a remote server and a management station, or to
send an alert to a pager.

Action Macros srvm.mcr Defines macros that define event and communication actions.

Events srvm.evt Defines events and RSM's actions that take place when each
event is triggered.

Security srvm.sec There is no Security File. Security is optional.  You must
customize it with Users, Passwords, and Permission Levels.

Keystroke Log Server.klg Contains the specific characters typed on the keyboard since
the last reset.  This file holds up to 128 characters and
discards any additional keystrokes beginning with the oldest
character.  You can transfer the Keystroke Log file to a
management station only.

CMOS Setup Server.cms Specifies the binary contents of CMOS memory.  When you
transfer CMOS memory to your management station, RSM
copies the entire contents of CMOS setup memory.  When
you transfer this file to a server, RSM copies everything in
CMOS setup memory except the time (Time contains zeros.).

EISA Configuration Server.ecu Specifies the binary contents of EISA configuration memory.

Firmware fw_main.abs Contains the firmware for the controller.

Extended BIOS  ebios.rom Contains the BIOS extension program for the controller.

RSM checks to make sure each file exists and is valid (proper directory, opened
by other, and so on) before transferring it to or from a remote server.  If you
attempt to transfer an Event, Action Macro, Script, or Security file larger than 2K
to a server, RSM displays an error message and does not transfer the file.

Transferring a blank Security file to a server disables RSM security.  RSM
displays a warning message that transferring a blank security file to a server
enables all users to perform all RSM functions.  Therefore, to enable RSM
security, make sure at least one user has Administrator privileges.
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The Keystroke Log displays the typed keys as follows:  

• Normal alphanumeric characters applied with Shift and CAPS as they are
typed.

• The CTRL+ALT, and/or Shift keys will display as bracketed <CTL->,
<ALT->, and/or <SHF->accordingly. For example, If you press the Ctrl
+ ALT+DEL keys, they will display in the Keystroke Log as:

<CTRL-ALT-DEL>

• Press Shift and any key. They display as follows:

<SHF-F1>   (SHIFT + F1)

• The CAPS LOCK key displays as CAPS-ON or CAPS-OFF.  The
remaining entries will reflect the positions of the U.S. 101 keyboard.

Transferring files and memory

1. Select Transfers on the Control window.  The Transfers window displays any
file names you previously entered in the Setup window's Default File Names
for Transfers window. Otherwise, the RSM default file names or <none>
displays.

2. Select a file type.  Press Tab.  Select a file name or enter a file name.  (Press
the CTRL key while selecting a series of file names to select multiple files.)

3. Select "To Server" to transfer the selected files from the management station
to the server.  Select "From Server" to transfer selected files and memory
locations from the server to the management station.

4. RSM transfers files in the order in which they display.  The file name, its
status, and the percentage of each file transferred also displays.
"Downloaded" or "Uploaded" displays after a successful file transfer.

5. The "To Server" and "From Server" buttons change to "Abort" during the
transfer process.  To cancel a transfer, select the appropriate (TO/FROM)
"Abort" button during the transfer process.

6. Select "Close" after the transfer process completes.  The Transfers window
closes.
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NOTES: If you attempt to transfer a file or memory that requires the server to be in
Held mode, RSM displays a warning message and stops the transfer.

Reset the remote server and set it into Held mode to successfully transfer a
CMOS setup or an EISA configuration.

To transfer an extended BIOS, the server should not be in HELD mode.
Heed the warning message that displays when downloading extended
BIOS.

If you transfer a corrupt or incorrect EISA Configuration file to a server
and have inadvertently reset the server before correcting this, you can
recover by referring to the resetting the EBIOS Address.  Refer to the
"Setting the Extended BIOS Address" paragraph in this section.

The size of the file may decrease if you transfer Event, Action Macro, or
Script files from a server. This is due to compression and/or elimination of
spaces, comments, and carriage returns.

CMOS memory comes in two basic sizes:  64 or 128 bytes.  All supported
Digital servers use the 128-byte CMOS.

RSM remembers any abort or failure that occurs during a transfer.  A
warning displays if you attempt to reset the firmware before successfully
completing a transfer.  RSM also remembers any abort or failure that
occurs during an EBIOS file transfer.  A warning also displays if you
attempt to reset the server before  successfully completing a transfer.

Using the Remote Diskettes Feature (Set Diskette)
RSM allows you to boot a remote server using diskettes or a diskette image file on
your management station or server through its Remote Diskettes feature. You can
also use this feature to transfer data or run diagnostics.

NOTE: The server must be in BIOS mode to use the Remote Diskettes feature.
Although you can start a remote diskette at any time, it operates only when
the server is in BIOS mode.
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Some operating systems and utilities can change the Server mode.  RSM
cannot detect this change.  If a change occurs, BIOS displays as the value
in the Server Mode field on the Server System Status window (Status
window).  Therefore, you need to know which Server Mode is currently in
use by the server software. DOS always uses the BIOS diskette calls.

Using the Remote Diskettes feature

1. Verify that the server is in BIOS mode and uses BIOS diskette calls.

2. Select Set Diskette on the Control window.  The Diskette Setup dialog box
displays.

                    

3. Select the drive on the remote server that you would like the remote server to
simulate: (A: or B:).

4. Select the Mode field.  Normal is the default. Change the field value by
selecting the scroll arrow and displaying a different mode.

5. Enter the file name with the correct path and drive, such as drive A: or B:,
when selecting either the At Management Station or M.S. Read only modes. If
you are using a diskette image file you may also use the Browse button to find
an image from a directory on your management station.

6. Select Set Diskette Configuration. RSM updates the current settings in the
Server Diskette Drives window on the Control window.
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The following table lists the Remote Diskettes Modes.

Mode Function

Disabled Disables the diskette drive on the server.

Normal (at Server) The server's diskette drive is the local drive.

Read only (at Server) Disables writing to the server's diskette drive.

At Management Station Uses the management station's diskette drive or an image file as
a remote drive for the server.

At M. S. Read only Uses the management station's diskette drive or an image file on
the management station for read only. Multiple servers can share
the read-only image file on either drive A or B.

NOTE: You may want to reset the CMOS setup for not attempting to boot from
drive A when setting the diskette mode to Disabled.  The Disabled and
Read only modes remain even when the server or controller loses power.

Do not use the Remote Diskette feature with the DOS SMARTDRV
program without using the "a-" or "b-" options on the SMARTDRV line.
Failure to use these options leads to very long diskette response times.

The server remembers whether a previous setting was Disabled or Normal
and reverts to that setting if the server is disconnected while in At
Management Station to At M.S. Read only mode.

Using a Management Station as a Remote Console
The Console window enables you to monitor a server console and enter keyboard
input remotely.  RSM takes control of the server’s keyboard and prevents input
from the server’s keyboard.  The Remote Console feature works when the server
is in text mode only.  It does not support graphic modes.

RSM sends management station keystrokes to the server when the Console
window is the active window.  RSM sends all keystrokes from an active Console
window to the server’s input or console port for processing by the server.
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Monitoring a VGA server console and entering keyboard input remotely

1. Select Open Console on the Control window. The Console Window displays.

2. To select another console other than the default console (for example, to use a
Serial console when VGA is the default), press and hold CTRL, and select
"Console".

3. Monitor the server console and enter keyboard input remotely.

4. Select Control from the menu bar.  The Control pull down menu displays.

5. Select Close from the Control pull down menu.

Remote Console Operation
The server’s VGA frame buffer must be readable from the EISA bus to use the
management station as a remote console.
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NOTE: The console window does not display when the server is in graphics mode,
for example, when NT is running.  You can still see some information by
opening a full screen MS-DOS window.  You can remotely control the
server through commands typed in the MS-DOS window using a remote
keyboard.

The Console window will be slightly different if the server screen is changing (for
example, scrolling or refreshing), because the server screen has changed by the
time the Console window receives its snapshot.  Once the server screen stops
changing, the Console window is identical to the server’s screen.

The Console window displays as an empty black screen when the server is
powered off.  If a connection to a server fails, RSM continues to display what was
on server’s screen.  The colors on the server may not be the same as the colors in
the Console window, because the application uses a non-standard color map.

Menu commands do not have keyboard equivalents in the Console window, since
Remote Server Manager sends all keyboard input directly to the server.  The bell
character causes a beep at the server, which is neither visible nor audible at the
management station.

Opening the Remote Console window makes the server keyboard nonfunctional.
The remote server keyboard LEDs reflect the management station keyboard
settings.

You may use a serial console in systems that redirect console output to a COM
port.  Otherwise, you must use a VGA console.

RSM Direct Connect
The Remote Server Management station can be setup to have a direct link to the
remote server through an RS232 serial line cable connecting the RSM board and
the station’s COM port.

1. Edit the rs_pm.ini  port communications file, and then setup a new server
without any connection values.
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2. Configure the serial port in Microsoft-Windows NT 3.51 Control Panel -
Ports

NOTE: The software will execute without the port manager running.

3. Run Setup.exe.

4. Edit the  \RS_MGR\rs_pm.ini  file

5. Identify the port initialization string to direct connect with a server name.
 rs_pm.ini
 [PORTS]
 com1=:d:server2
 com1   =  :d            :  server2
 This example identifies Com port 1 ,  No Modem   Direct :  server name

6. Execute the RSM software.

7. Select any server name and choose  “Setup”  The Setup screen for the new
server displays.

8. Choose “New”  from the Setup screen.

9. Setup the server as “server2”.  Open <new action> in the Connection
Actions window and select “No Connection”.  Default files are not important
for setup.
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10. Purchase or construct a null modem cable (refer to the Remote Server
Manager Hardware Installation Guide).

11. Open the Control Panel and select “Ports Setup”.  The following screen
displays:
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12. Set the following values in the Settings window:
Baud rate 38,400  (This is the speed at which the communication

port on  the RSM  board communicates)
Data Bits 8
Parity None
Stop Bits 1
Flow Hardware

13. Select “Advanced ...”.  The following screen displays:

14. Set the I/O Port and IRQ in the Advanced Settings window to the default
value or to another value.

15. Select “FIFO Enabled”.

NOTE: The RSM board design requires that the Carrier Detect signal in the RS232
cable.
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Menus and Preferences �
This chapter describes the Remote Server Manager (RSM) menu bar commands.

Remote Server Manager Menu Commands
The RSM menu bar contains six commands: File, Edit, Functions, Options,
Window, and Help.  The menu commands follow the industry-standard Windows
conventions.

Menu Conventions
The following table summarizes the menu commands conventions.

Convention Meaning

Dimmed command name The command is not available for the selection.

An ellipsis (…) after the name A dialog box displays after you select this command
for additional information.

A check mark (�) next to the name The command is active.  Used for commands that
toggle between one state and another.

A key combination after the name The keyboard key combination for this command.

Triangle (right side of a menu command) This command maximizes and minimizes the window.

Control Menu
RSM uses the standard Windows control menu, located in the upper left corner.

Opening the Control menu

1. Select the Control menu box located in the upper left corner (indicated by a
hyphen).  Move the mouse pointer to the Control menu icon and click, or
press ALT+SPACEBAR.  The Control menu pull-down menu displays.
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2. Select a command.  Press ALT if you want to close the menu without
choosing a command.

The following table lists and explains the Control menu commands:

Command Description

Restore Restores the window to its former size after it has been enlarged
(using the Maximize command) or shrunk to an icon (using the
Minimize command).

Move Allows you to use the keyboard to move the window to another
position on the desktop.

Size Allows you to use the keyboard to change the size of the window.

Minimize Shrinks the window to an icon.

Maximize Enlarges the window to its maximum size.

Close Closes a window and removes it from the list of active windows on
the Window menu.  If you try to close a window without saving any
changes, RSM asks if you want to save the information before
closing the window.  For a dialog box, it closes the dialog box without
completing the command.

Task (Switch To…) Starts Task List.  This lets you switch among running applications.

File Menu
The File menu has four possible logical groups.  These groups are specific to the
connection in the active window, so not all groups are present for all windows.

The following table describes the File menu commands.

File Command Description

Save As Saves file to a specified file name.  Saves the contents of a Console
window into a specified file.

Export) Adds server status into a file.

Print Prints server status.

Print Setup Provides standard printer setup information, such as printer name,
type of form, page orientation, number of sides to be printed,
document properties, and network connections.

Exit Exits RSM.  If the Save Window Layout option is on, RSM saves the
window arrangement.  If the window has any information that was
changed and not saved, RSM asks if you want to save this
information before exiting.
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Edit Menu
The Edit menu commands are specific to a connection in an active window and
are not available in all windows.  The following table describes the possible Edit
menu commands

Command Description

Cut Removes the selection and places it on the Clipboard.

Copy Copies the selection onto the Clipboard.  Copies the Console window
contents to the Clipboard.

Paste Copies Clipboard contents into the active window.

Delete Deletes a selected command.

Select All Selects entire contents of the window.

Functions Menu
The following Function menu illustration does not show all the commands that
might display.  The function menu commands are specific to the connection in an
active window and are not available in all windows.  The following Functions
menu displays from the Control window.
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The following table lists and explains all the possible Function menu commands.

Command Description

Connect/Disconnect Connects to a server.  Disconnect displays after a successful
connection is made to a remote server.

Edit Setup Displays a Setup window for the active server.

Open Console Displays a Console window for the active server.

Show Control Displays the Control window for the server in the active window.

Transfer to/from Displays a Transfers window for the active server.

Update Status Updates the status of the active server.

View Status Displays a Status window for the active server.

Power Off/Power On Displays the Power On/Power Off dialog box.

Reset/Keys Resets the server or sends the server special key commands.
Displays the Reset/Keys dialog box.

Release Releases server from Held mode.

Remove Removes a selected server(s). A confirmation box displays to confirm
each server deletion.  You can suppress individual delete confirmations
by selecting YES-TO-ALL in the Confirmation dialog box.

Setup New Opens a Setup window with all fields blank.  This command is an
alternative to the New button on the Setup window.

Set Clock Displays the Set Clock dialogue box.

VGA Console Displays the active server's VGA Console window.

Set Diskette Displays the remote diskette settings

Options Menu
The following Options menu illustration displays the Options menu commands for
a VGA connection.
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The following table lists and explains the Options menu commands for a VGA
console connection.

Command Description

Preferences Displays the Preferences dialog box.

Events Displays a submenu consisting of:

New - displays the Events Definitions dialog box.

Open- displays the Open event definitions file dialog box. Select a file and select OK.
The Events Definitions dialog box for that file displays.

Delete- displays the Delete event definitions file dialog box. Select a file and select
OK.  A confirmation dialog box displays. Select OK to delete the event file.

Macros Displays a submenu consisting of:

New - displays the Macros Definitions dialog box.

Open- displays the Open macro definitions file dialog box. Select a file and select OK.
The Macros Definitions dialog box for that file displays.

Delete- displays the Delete macro definitions file dialog box. Select a file and select
OK.  A confirmation dialog box displays. Select OK to delete the macro file.
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Command Description

Scripts Displays a submenu consisting of:

New - displays the Scripts Definitions dialog box.

Open- displays the Open Scripts Definitions File dialog box. Select a file and select
OK to display the Scripts Definitions dialog box for that file.

Delete- displays the Delete Script Definitions File dialog box. Select a file and select
OK.  A confirmation dialog box displays. Select OK to delete the scripts file.

Security Displays a submenu consisting of:

New - displays the Security Definitions dialog box.

Open- displays the Open Security Definitions File dialog box. Select a file and select
OK to display the Security Definitions dialog box for that file.

Delete- displays the Delete security definitions file dialog box. Select a file and select
OK.  A confirmation dialog box displays. Select OK to delete the security file.

Sort by Name Displays servers in alphabetical order by name.

Sort by Last Contact Displays servers in order based on the time of the last connection.

Sort by Connect Time Displays servers in order based on the elapsed time of the connection.

Sort by Alert Pending Displays servers with pending alerts.

Ascending Sorts in ascending alphanumeric order (A-Z, 0-9)

Descending Sorts in descending alphanumeric order (Z-A, 9-0)

Windows Menu
The Windows menu commands are specific to the current connection and are not
available for all connections.
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The following table lists and explains the Windows menu commands.

Command Description

Cascade Displays windows by offsetting a window lower and to the right of a
previously visible window.

Tile Displays windows in screen quadrants.

Tile Server Arranges the remote server's open Control, Status, Setup, and
Console window in screen quadrants. If the active window is a Select
window, the server selected is the one that tiles.  If there are multiple
selected servers in the active window, the first selected server tiles.

Close Server Closes all open windows for the selected server.

Close All Closes all open windows.

Get Select Displays a submenu with New and Select.  New displays a blank
Select window.  Select displays a previously created Select window.

Get Options Makes an existing Options window the active window.

Server Window List Switches to a new or different window for a particular server.  A
submenu listing Tile, Close, and access to the RSM configuration
windows displays.
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Help Menu
The following table lists and explains the Help menu commands.

Command Description

Contents An alphabetic list of all Help topics.

Search for Help on A dialog box for locating information about a specific topic.

How to Use Help Information on using Windows Help.

About … RSM Information including product name, version, company name,
and copyright version.

User Preferences
You can change RSM defaults to reflect your individual preferences using the
Preferences command on the Options menu.   Specific Preferences include Celsius
or Fahrenheit as the temperature scale, user information, Server Attribute Names,
as well as other application-wide settings.

Preferences Window
The Preferences window enables you to view and change various global
application settings.

Opening the Preferences window

1. Select Options from the menu bar. The Options pull-down menu displays.

2. Select Preferences from the Options pull-down menu.  The Preferences
window displays.
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Entering User Information

1. Enter the user name.  The User Name can be up to 20 characters.

2. Enter a password for the user, then press Enter.  A password is required if the
server Security file uses password security to access the controller.  The
password can contain up to 12 characters.  An asterisk displays for each
password character.

3. A Confirm Password dialog box displays.  Enter the password again.

NOTE: Since the foundation of RSM security is Windows NT security, be sure to
utilize secure password administration and Windows NT security
procedures to safeguard your RSM user password.

Server Attribute Names
You can define an unlimited number of server attributes names.  Each name can
have up to 8 characters. The name that you enter here displays in a scrollable list
in the Setup window's Server Names and Attributes pane.

Server attribute names and server attribute values can be used with the filter
option to limit the displayed servers in the Select window to only those that meet
certain criteria.  Refer to Chapter 2, Getting Started, for more information about
entering Server Attributes Values for a server.  Refer to Chapter 3, Basic Tasks,
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for more information about using server attribute names and values with the filter
option.

Inserting a server attribute name into an existing list

1. Select the line before the one where the new entry is to appear.

2. Select Insert.  The line you selected moves down one line.

3. Enter the additional server attribute name.
Deleting a server attribute name

1. Select a server attribute name.

2. Select Delete.

Options
You can change an Options field value by selecting it.  The fields display either an
X (Off) or a check mark (On),  except for the temperature scale, which displays
either an F (Fahrenheit) or a C (Celsius).

The following table lists and explains the Preferences window options

Field Description

Temperature Scale Displays the temperature scale in Celsius (default) or Fahrenheit.

Confirm All Deletions Displays a dialog box to confirm (default) a server deletion.

Connect on Open Control Allows you to automatically connect to a server each time its
Control window opens and it is not already connected.  The default
is no automatic connect.

Disconnect on Control Close Automatically disconnects server connections when you close a
Control window.  This option will not disconnect any servers with
activities, such as transfers still in progress).  The default is no
automatic disconnect.

Open Console on Connect Automatically opens a Console window after you select the Control
window Connect button.  The default is not to automatically open a
Console window.

Save Windows Layout If this mode is On (default), saves the selected window
arrangement after you quit RSM.  The window arrangement is not
saved if the option if off.

Newline> Tab Allows you to use the ENTER key to advance to the next field
(default).



Menus and Preferences

77

Global Accelerator Commands
Global Accelerator keys can be used to perform operations from the keyboard.
The command operations apply to all active servers.  If a command operation does
not apply, a beep sounds.  The following table lists and defines the Global
Accelerator Commands.

Accelerator Keys
(CTRL+ ALT+)

Definition

Escape Aborts any server operation in progress

C Select the active server's Control window

E Select the active server's Setup window

H Help (same as selecting Contents from on-line Help)

N Open a window to Setup a new server

Q Quit Remote Server Manager

O Open the default console (SHIFT+O to open the other console)

S Select the active server's Status window

T Select the active server's Transfer window

V Select the active server's VGA console window

W Tile the active server's windows (press SHIFT+W to close the tiled windows)

Page Up Tile the previous active server (press SHIFT+PAGE UP to close the current
server windows)

Page Down Tile the next server (press SHIFT+PAGE DOWN to close the server's windows)

F1 Console windows (press F1 to send through to the remote host)

1, 2, 3, 4 Tile 1, 2, 3, or 4 windows
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The following table lists and defines the Accelerator Keys.

Accelerator Keys (CTRL+) Definition

A Select All.  This is specific to an active server (all servers in the
Select window, and all log entries in the Status window)

B Clear a selected editable field

C Copy selected command(s) to the Clipboard

P Print server information

S Save a file

V Paste text from the Clipboard to an editable file

X Cut the selected text
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Files�
This chapter describes how to edit server configuration files, including events,
macros, scripts, and security files.  The end of the chapter summarizes the server,
server log, and preferences files.  Refer to Chapter 4, Advanced Functions, for
information on transferring these and other files.

RSM provides files for the events, macros, and scripts files.  The file names are
srvm or examplex (x signifies a number, starting with 1) plus the appropriate
extension (.evt, .mcr or .scr).  Refer to Appendix B, File Examples, for more
information.

All the files described in this chapter are in ASCII text format.  This allows you
to edit RSM files with any standard text editor.  This offers a fast way to start up
and make changes to networks with a large number of servers.

The RSM customized file editors provide an easy and fast way to create, edit, and
delete configuration files.  The RSM file editors all have the same user interface
and behavior, with Insert, Delete, and Save buttons.  All changes display as blue
text until you save the file.

This chapter describes the following kinds of files:

• Events—Defines the server conditions RSM should monitor and the
actions it should take when these conditions exceed specified limits.
Refer to the events file srvm.evt.

• Macros—Defines macros.  Macros can define single or multiple actions
that occur in an event or a connection action.  Refer to the file srvm.mcr
for an example of a macros file.

• Scripts —Defines communication dialogs used to make a connection
between a management station and a server or to send an alert to a pager.
A script is a sequence of alternating “expected input” and “next output to
send” pairs that define a dialog via a serial port.  Refer to the file
srvm.scr for an example of a scripts file.
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• Security8 —Defines user names, their groups, and passwords.  Refer to
the file srvm.sec for an example of a security file.

• Server—Defines server names and attributes, connection actions, and
default file names for transfer.  The server file extension is .sdf.

• Server Log—Defines time-stamped log files for each server.  The server
log file extension is .log.

• Preferences—Defines global application settings, including window
arrangements and user preferences, that provide continuity across
multiple RSM sessions.  The preferences file extension is .prf.

Events Files
An events files list the server conditions RSM monitors and the actions it takes
when these conditions exceed specified limits.  The controller regularly checks the
server status and compares the current values against those listed in the server's
events file.  If an event has occurred, the controller performs the actions as listed
in the server's events file.

The events file, srvm.evt, and Appendix B, File Examples, show examples of
some typical server conditions RSM monitors and automatic actions that it
performs.

                                                  

8 The maximum size of a server configuration file is 2K.  If you attempt to transfer a bigger configuration field, the transfer fails and
an error message displays.
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Defining Events
RSM defines an event as:

<state> <sensor parameter> <test> <limit> <action1>,
<action2>...

The statement means:  when the server is in a specific state <state>, and the
<sensor parameter> does a comparison test <test> and the value <limit> is true,
perform the actions in the order as they occur <action1>, <action2>.  An event
occurs only when the comparison goes from false to true.  If an event  remains
true the next time, a new event will not occur and RSM checks the sensors.

Adding and Changing Event Definitions
The RSM Event Definitions window enables you to:

• Define the server conditions that the controller monitors

• Define the actions to take when a server condition exceeds a specified
limit

You can create new events files and change existing files.  RSM provides an
example events file (srvm.evt). You can customize this file or create your own.

Creating a new events file

1. Select Options from the menu bar.  Move the mouse pointer to Options and
click, or press ALT +O.  The Options pull-down menu displays.

2. Select Events from the Options pull-down menu.  The Events submenu
displays.

3. Select New from the Events submenu.
Editing an existing events file

1. Select Options from the menu bar.  The Options pull-down menu displays.

2. Select Events from the Options pull-down menu.  The Events submenu
displays.

3. Select Open on the submenu.
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4. Enter the file name in the File Name text box, or choose the file name of the
Events file on the Open dialog box.

5. Select OK on the Open dialog box.
The Event Definitions window displays after you complete any of the above
procedures.  The window title bar displays the name of the file being edited, or
<unnamed_n> until you save a New file.  The Event Definitions window displays
blank for a New file, and displays the applicable information for previously
created events.
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Defining Sensor Parameters
Defining an event when a server's +3.3V power sensor parameter is outside the +3.0V
to 3.6V range

1. Select <new event> from the Parameter menu.  The Parameter option box
displays.

2. Select the scroll arrow to display the available parameter options.
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3. Select +3.3V power.  The default parameters for the connection in the active
window display.

• The default test symbol is ][ (outside the range).  Since you are testing a
server condition that exceeds the specified lower and upper limit, proceed
to step 4.

• Select the default test symbol. The Test options display with a scroll
arrow.  Select the scroll arrow to view the other test symbols and select
the applicable symbol.

You can define up to 100 events.

NOTE: If you enter a number with either a - or + sign, the sign must precede the
value with no leading spaces.  Use a comma to separate any values that you
are testing that are inside or outside a range..  The values always display in
ascending numerical order even if you enter them in descending numerical
order.
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The following table lists all of the sensor parameters and their default values:

Parameter Default

+3.3V power Outside  +3.0V to +3.6V range.

+5V power Outside  +4.5V to +5.5V range.

+12V power Outside  +11.0V to +13.0V range.

-5V power Outside  -4.5V to -5.5V range.

-12V power Outside -11.0V to -13.0V range.

Temperature* Greater than 27ºC (80ºF).

Temp Deg/hr* Greater than 1ºC (1ºF).

Ext Pwr (V) Outside 4.5 to 5.5 range.

Keystrokes Greater than 0.

Server mode Equal to INIT.

*  RSM converts Temperature from Celsius to Fahrenheit on the Preferences window Options pane.  Refer to the
User Preferences section in Chapter 5, Menus and Preferences.

Event Tests
The Test  field displays the test symbol associated with the parameter you
selected.  Only test symbols available for the connection in the active window are
displayed.
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The following table lists and explains the event test symbols.

Test Description

== Equal

!= Not equal

[ ] Inside

] [ Outside

> Greater than

< Less than

Defining Event Actions
Use the Actions Associated with Selected Event window to define the actions
RSM must take when an associated event occurs.  You can define single or
multiple event actions for each sensor parameter.



Files

87

Defining an event action to power off the server when the server temperature is too
high

1. Choose <new action> from the Actions Associated with Selected Event pane.
The <new action> pull-down menu displays.

2. Select the arrow located on the right of the <new action> pull-down menu.
The <new action> options display.

3. Select Power from the pull-down menu.  The pull-down menu closes and
Power displays with its defaults.  The default value for Power is On and
displays in the <new value> field.
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4. Select On.  A scroll arrow displays on the right side of the <new value> field.

5.  Select the arrow.  On and Off display. Select Off.
The following table summarizes the actions and values in an event definition.

Action Description

Boot=type Do a boot or reset.  Type can be reset, cold, or warm.

Hangup Hang up the serial port.

Include=command Perform additional actions, as specified in the line starting with the
command command in the Macros file.

Log with Tag=log Make a log entry with Tag 0-255.

Pause=pause Wait pause seconds before proceeding to the next action.
pause=0-99 (2-digit field).

Power=on-off Set power.  On-off can be on or off.

Retry=n Repeat the actions n times if a connection fails. n=0-99 (2-digit
field).

Script=script Execute the script with the name script.

Send Alert Send an alert.  If the telephone line is unavailable, an alert is not
sent.

Speed=baud Set the baud rate of the serial port to baud  300, 1200, 2400,
4800, 9600, 14400, 19200, 38400, or 57600.

State=state 9 Enter State.  State=0-255 (3-digit field).

Stop on Failure?=yes or no Stop or continue subsequent actions if an action fails. Options are
yes or No.  If the value is yes, stop if an action fails.If the value is
no, continue with subsequent actions if an action fails.  The
default is Yes.

Stop on Success?=yes or no Stop or continue subsequent actions after a successful action.
Options are yes or No.  If the value is yes, stop if an action
succeeds.  If the value is no, continue with subsequent actions if
an actions succeeds.  The default is No.

Telephone=number Set the telephone number to number.  Number is the number to
be dialed, including the normal dial escape codes.

                                                  

9 A State variable is useful when you want RSM to conditionally perform an action.  For example, you may want to perform an action
only when the server power is either Off or On
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Conditionally performing an event action

1. Enter a nonzero value for state.

2. Enter a state event action with the same nonzero value when you define the
associated event actions that should be performed conditionally.

Inserting, Deleting, and Reordering Event Definitions
Sensor parameters and event actions can be inserted, deleted, and reordered with
the buttons at the bottom of both panes on the Event Definitions window.  The
Insert button inserts an entry before the currently selected entry.  The Delete
button deletes the currently selected entry.  The arrows at the bottom right of each
pane enable you to reorder the entries.

Inserting an entry into an existing  list

1. Select the line before the one where the new entry is to appear.

2. Select Insert.  The selected line moves down one line.

3. Enter the additional entry.
Deleting an entry

1. Select an entry.

2. Select Delete.
Reordering an entry

1. Select an entry.

2. Select either the up arrow button or the down arrow button.  The up arrow
button moves one line up the list each time you select it.  The down arrow
button moves one line down the list.

3. Select either the number of times you need to move the selected entry to a spot
on the list.
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Saving Events Files
When you have completed the event definition, save it as a file for future use.

Saving an Events file

1. Select File from the menu bar.  The File pull-down menu displays.

2. Select Save or Save As from the File pull-down menu.  The Save dialog box
displays.

3. Select an Events file name from the File Name pane, or enter a file name in
the File Name text box.

4. Select OK to save the file.

Macro Files
Macro files contain macro definitions.  These files are optional.  You can use
macros to define single or multiple actions that occur in an event or a connection
action.  With the Macro Definitions window, you can create new and edit existing
macros files that can be subsequently transferred to a server. Refer to the file
srvm.mcr or Appendix B, File Examples, for examples of a Macro file.

Creating a new macros file

1. Select Options from the menu bar.  The Options pull-down menu displays.

2. Select Macros from the Options pull-down menu.  The Macros submenu
displays.

3. Select New from the submenu.
Editing an existing macros file

1. Select Options from the menu bar.  The Options pull-down menu displays.

2. Select Macros from the Options pull-down menu.  The Macros submenu
displays.

3. Select Open from the submenu.

4. Enter the file name in the File Name text box, or select a macros file name of
the Macros file from the File Name box.

5. Select OK from the Open Macro dialog box.
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The Macro Definitions window displays after you complete any of the above
procedures.  The window title bar displays the name of the file being edited, or
<unnamed_n> until you save a new file.  The Macro Definitions window displays
blank for a new file, and displays the macro name, action, and value for
previously created macros.

Adding and Changing Macro Names
Macros display in the Macro Name pane.

Creating a macro

1. Select <new macro> on the Macro definition window.

2. Enter a new macro name (up to 32 characters).
Editing an existing macro

1. Select the macro you want to change from the Macro Name pane.

2. Enter a new macro name (up to 32 characters).
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Inserting and Deleting Macros
Macros can be inserted and deleted with the Delete and Insert buttons at the
bottom of the Macro Name pane.  The Insert button inserts a macro before the
currently selected name.  The Delete button deletes the selected macro.

Inserting a macro into an existing macro name list

1. Select the line before the one where you want to insert the macro name.

2. Select Insert.

3. Enter the macro name.
Deleting a macro

1. Select the macro name you want to delete.

2.  Select Delete.

Defining Macro Actions
Use the Actions in a Selected Macro pane to define the specific macro actions.

Defining a new macro action

1. Select <new action> from the Macro Actions pane menu.  The <new action>
pull-down menu displays.
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2. Select a macro action.  It displays in the Action field.  RSM automatically
enters a default value for some macros.  If the default value is incorrect,
continue to step 3.

3. Select Value from the Macro Action pane, or enter the macro value
information.  Select the default value if one exists.  Another pull-down menu
displays.

4. Select the scroll arrow on the pull-down menu and select another value.
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The following table summarizes the actions and values in a Macro Definition:

Action Description

Boot=type Do a boot or reset.  Type can be reset, cold, or warm.

Dialback Dial back to the management station.

Hangup Hang up the serial port.

Include=command Perform additional actions, as specified in the line starting with the
command command in the Macros file.

Log with Tag=log Make a log entry with Tag 0-255.

Pause=pause Wait pause seconds before proceeding to the next action.  Pause=0-99
(2-digit field).

Power=on-off Set power.  On-off can be on or off.

Retry=n Repeat the actions n times if a connection fails. n=0-99 (2-digit field).

Script=script Execute the script with the name script.

Send Alert Send an alert.  If the telephone line is unavailable, an alert is not sent.

Speed=baud Set the baud rate of the serial port to baud  300, 1200, 2400, 4800,
9600, 14400, 19200, 38400, or 57600.

State=state Enter State.  State=0-255.

Stop on Failure?=yes-no Stop or continue subsequent actions if an action fails.  Yes-no can be
yes or no.  If yes-no is yes, stop if an action fails.  If yes-no is no,
continue with subsequent actions if an action fails.  The default is yes.

Stop on Success?=yes-
no

Stop or continue subsequent actions if an action succeeds.  Yes-no can
be  yes or no.  If yes-no is yes, stop if an action succeeds.  If yes-no is
no, continue with subsequent actions if an action succeeds.  The default
is no.

Telephone=number Set the telephone number to number.  Number is the number to be
dialed, including the normal dial escape codes.

Inserting, Deleting, and Reordering Macro Actions
Macro actions can be inserted, deleted, and reordered with the Delete and Insert
buttons at the bottom of the Actions in Selected Macro pane.  The Insert button
inserts a macro action before the currently selected macro action.  The Delete
button deletes the selected macro action.  The arrowheads in the bottom right
corner of the Actions in Selected Macro pane enable you to reorder your macro
actions.
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Inserting a macro action into an existing macro action list

1. Select the line before the one where you want to insert the macro action.

2. Select Insert.

3. Enter the Macro Action.
Deleting a macro action

1. Select the macro action you want to delete.

2. Select Delete.
Reordering a macro action

1. Select the macro action.

2. Select either the up arrow or the down arrow button.  The up arrow button
moves one line up each time you select it.  The down arrow button moves one
line down.

3. Select the up or down arrow button until you reach the location where you
want to move the macro action.

Saving Macros Files
Save the macro file after you have completed defining it.

Saving a Macros file

1. Select File from the menu bar.  The File pull-down menu displays.

2. Select Save or Save As from the File pull-down menu.  The Save dialog box
displays.

3. Enter the file name in the File Name text box or select a macros file from the
Save dialog box.

4. Select OK from the Save dialog box.
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Script Files
Script files contain communication dialogs that are used to make a connection
between a management station and a server, or to send an alert to a pager.  A
script is a sequence of alternating "expected input" and "next output to send" pairs
that defines a dialog over a serial port. The RSM Scripts files contain multiple
scripts.  Each script is identified by a script name and consists of one or more
steps.  You can add a new scripts file, or edit an existing one that can be
subsequently transferred to a server.  Refer to the scripts file srvm.scr or to
Appendix B, File Examples, for examples of a Scripts file.

NOTE: If RSM sends alerts to the management station, verify that the correct
scripts are being used for the modem installed on the remote server and the
management station.  An incorrect scripts file on the server may cause the
modem to remain in an unusable state.  To overcome this, someone must
have physical access to the server to reset the controller to its factory
defaults.

Adding and Changing Script Definitions
Creating a new scripts file

1. Select Options from the menu bar.  The Options pull-down menu displays.

2. Select Scripts from the Options pull-down menu.  The Scripts submenu
displays.

3. Select New from the submenu.
Editing an existing scripts file

1. Select Options from the menu bar.  The Options pull-down menu displays.

2. Select Scripts from the Options pull-down menu.  The Scripts submenu
displays.

3. Select Open from the Scripts submenu.  The Open Script dialog box displays.

4. Enter the file name in the File Name text box, or select a script file name.

5. Select OK from the Open dialog box.
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The Script Definitions window displays after you complete any of the above
procedures.  The window title bar displays the name of the file being edited, or
<unnamed_n> until you save a new file.  The Script Definitions window displays
blank for a new file, and displays the scripts name, step type, and value for
previously created scripts.
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Adding and Changing Scripts
The previously saved scripts files display in the Script Name pane.

Defining a new script

1. Select <new name> from the Script Name pane.

2. Enter a new script name.  The script name can contain up to 32 characters.
Changing an existing script

1. Select the script name you want to change.

2. Enter a new script name. The script name can contain up to 32 characters.

Inserting and Deleting Scripts
Scripts can be inserted and deleted using the Delete and Insert buttons at the
bottom of the Script Name pane.

Inserting a script into an existing script name list

1. Select the line before the one where you want to insert the script name.

2. Select Insert.

3. Enter the script name.
Deleting a script

1. Select a script name.

2. Select Delete.
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Defining Script Steps
The Steps in Selected Script pane lists the steps for a selected script.

Defining a new script step

1. Choose <new step> from the Steps Type pane.  The Step Type pull-down
menu displays.

2. Select a step type.  RSM displays the default value, <none>, for each step.
Proceed to step 3 to add a new value.

3. Select <new value> from the Value pane.  Enter the Step Value information.
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The following table summarizes the possible steps in a script definition:

Step Description

Expect string Expect string.

Send string Send string.

Conditional Expect string If previous send failed, expect string.

Conditional Send string If previous expect failed, send string.

Abort string Abort the script.  Abort string causes the script to abort if RSM
receives string before the script completes.

Timeout time Timeout time results in a wait of time seconds in executing each
step.  If the next step does not arrive within time seconds, the
script aborts.

Delay delay Delay pause seconds before proceeding to next action. Pause=0-
99 (2-digit field).

Parity parity Set the serial port parity Even parity (the default), Odd parity, No
parity, or set parity to On.

Inserting, Deleting, and Reordering Script Steps
Script steps can be inserted, deleted, and reordered with the Delete and Insert
buttons at the bottom of the Steps in Selected Script pane.  The Insert button
inserts a script step before the currently selected step.  The Delete button deletes
the selected step.  The arrow buttons in the bottom right corner of the Steps in
Selected Script pane enable you to reorder steps.

Inserting a script step into an existing script step list

1. Select the line before the one where you want to insert the script step.

2. Select Insert.

3. Enter the script step.
Deleting a script step

1. Select a script step.

2. Select Delete.
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Reordering a script step

1. Select a script step.

2. Select either the up arrow button or the down arrow button.  The up arrow
moves one line up each time you select it.  The down arrow moves one line
down.

3. Select the up or down arrow button and reinsert the script step on the list.

Saving Scripts Files
Save any new or changed scripts files for future use.

Saving a scripts file

1. Select File from the menu bar.  The File pull-down menu displays.

2. Select Save or Save As from the pull-down menu.  The Save dialog box
displays.

3. Enter the file name in the File Name text box, or select a script file name.

4.  Select OK from the Save dialog box.

Security Files
Security files contain user names, groups, and passwords.  You can define up to
100 users.  You can specify user names, groups, and passwords with the Security
Definitions window and save this information in a security file.

NOTE: The controller is shipped from the factory with the security features
disabled. Normally the security features on the controller are set from the
remote server management station. The security modes and passwords are
saved in the non-volatile memory on the controller.   To reconfigure the
controller board, refer the Remote Server Manager Hardware Installation
Guide.

Refer to the security file, srvm.sec, for an example of a Security file.
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Specify the functions users can perform by assigning them to one of three groups:

• The User group can access a server, view server status, use a
management station as a remote console, and transfer Events, Macros,
Scripts, Firmware, and Extended BIOS files from a server to the
management station.

• The Super User group can do all RSM functions except resetting the
firmware and transferring security, firmware, and extended BIOS files
from the management station to a server.

• The Administrator group  can perform all RSM functions.

Creating a new Security file

1. Select Options from the menu bar.  The Options pull-down menu displays.

2. Select Security from the Options pull-down menu.  The Security submenu
displays.

3.  Select New from the submenu.
Editing a Security file

1. Select Options from the menu bar.  The Options pull-down menu displays.

2. Select Security from the Options pull-down menu.  The Security submenu
displays.

3. Select Open from the submenu.

4. Select a security file name from the File Name pane on the Open dialog box,
or enter a security file name in the File Name text box.

5. Select OK from the Open dialog box.

NOTE: Transferring a blank security file to a server eliminates RSM security.
RSM displays a warning message if you attempt to save a security file with
no user information.  Confirm to save.

Verify that the security file that you transfer to a server has at least one
user with Administrator privileges.
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The Script Definitions window displays after you complete any of the above
procedures.  The window title bar displays the name of the file being edited, or
<unnamed_n> until you save a new file.  The Script Definitions window displays
blank for a new file, and displays the user names, groups, and user passwords
when you edit a specified file.

Entering User Names
Entering a new user

1. Select <new user> from the User Name field on the Security Definitions
window.

2. Enter a user name.  The user name can contain up to 20 characters.  RSM
displays User as the default group.  If the user is in the User Group, continue
to step 3.  Otherwise, select User to display the group options.
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3. Enter the user’s password (if you use RSM passwords). The password can
contain up to 12 characters.  A Confirm Password dialog box displays.  Re-
enter the password.

Inserting, Deleting, and Reordering User Names
User names can be inserted, deleted, and reordered with the Delete, Insert, and
arrowhead buttons at the bottom of the User Name pane of the Security
Definitions window.  The Insert button inserts a new user name before the
currently selected User Name.  The Delete button deletes the selected user name.
The arrow buttons in the bottom right corner of the window enable you to reorder
the user names.
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Inserting a user name into an existing user name list

1. Select the line before the one where the user name is to appear.

2. Select the Insert button.  If a user name already resides on that line, it moves
down one line.

3. Enter the user name.
Deleting a user name

1. Select a user name.

2. Select Delete.
Reordering a user name

1. Select a user name.

2. Select either the up arrow button or the down arrow button.  The up arrow
moves one line up each time you select it.  The down arrow moves one line
down.

3. Select the up or down arrow button and reinsert the user name on the list.

NOTE: If you forget your Administrator password, you will need to reset the RSM
controller to all its default file, factory defaults (no security) before you can
perform any function that requires Administrator privileges.

You must have physical access to the remote server to power cycle the
controller with an attached jumper. Refer to the RSM Hardware
Installation Guide for more information.

Saving Security Files
Saving a security file

1. Select File from the menu bar.  The File pull-down menu displays.

2. Select Save or Save As from the pull-down menu.  The Save dialog box
displays.

3. Enter the file name in the File Name text box, or select a security file name.

4.  Select OK from the Save dialog box.
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Server Files
A server file contains summary server information.  Each server has its own file
with the server short name as the file name and an extension of .sdf.  A server file
contains the following information:

• Server's short name and long name

• Connection information

• Default file names for transfers

• Server status information.

You can create and modify server files on the Setup window.  If RSM cannot find
any server files, it displays a warning message.  This message displays the first
time you use RSM, since you have not defined any servers yet.

Server Log Files
The server log files contain time-stamped log files for each server.  Server log
files have the extension .log.

The server log file is the only RSM file that can grow to any significant sizeRSM
adds each event to the server log file as it occurs.  This file grows quickly if you
define sensor parameters so that you receive many events.  If you define sensor
parameters so that you get only a few events, this file will  remain small.  Back
up and/or delete any server log files to meet the needs of your specific operation.

Preferences File
The preferences file contains global application settings.  This file provides
continuity by allowing you to keep the same user preferences and window
arrangements from the previous session each time you start RSM.  RSM uses the
default settings if it cannot find this file at startup.
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Troubleshooting  �
This chapter summarizes problems that can occur and tips on how to solve them.
Typical errors are often due to common file operation errors, for example, when
RSM cannot find a file due to a mistyped filename or an incomplete path.

Fatal errors occur due to insufficient memory or failed internal program
consistency checks.  RSM notifies the users of the problem and exits.  Out-of-
memory errors rarely occur on virtual memory operating systems.

Startup Errors
RSM checks for the existence of application and user files each time it starts.  It
creates a default file if no user Preferences file exists.

RSM displays a warning immediately after installation if cannot find any Server
files.  Confirm you want to continue by selecting OK.

Out-of-Disk-Space Error
RSM displays an error message and cancels the save if it encounters an out-of-
disk-space error during a save operation.  This can happen when you save setup
information and when you use Export and Print commands.  You can switch to
another application to delete some files or clean up your disk, and then return to
RSM to retry the save operation.

Any alert that occurs when there is no available disk space on the management
station will be lost.

Help Error
RSM displays a warning message (Can't find help file) and cancels any Help
operation if it cannot find a Help file.
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Troubleshooting Tips
The following tables provides troubleshooting tips for connection and
miscellaneous problems.

Problem Explanation Solution

You cannot connect to a server at
startup even though the
Connection Status pane displays
the message "Script executed
without error."

All modem cables must be
connected before the server's power
is on.

Reattempt to connect to the server.

If you still cannot connect to the server,
have someone at the server site reset or
power cycle the controller.

At startup, you cannot connect to
a server.  The connection status
pane displays the message "No
serial port is available" when you
press Connect.

The flow control setting for the COM
ports in Windows NT Control Panel
is None.

Change the flow control setting to
Hardware in the Ports section of the
Control panel.

You cannot connect to a server
immediately after an alert arrives.
The message "No serial port is
available" displays when you
press Connect.

The port is currently in use.  It can
take a modem several seconds to
terminate a call.

Wait several seconds after an alert
arrives before pressing Connect.

You cannot connect to a server.
The connection status pane
displays the message "No serial
port is available" whenever you
press Connect.

All serial ports are currently in use.

The Port Manager did not start or it
exited with an error.

The port is set up incorrectly.

Use the Port Manager window to verify
that the serial port is operating in both
originate and answer modes.

If your modem has a DTR LED, check to
ensure that DTR is on.

If DTR is off, check the Port Manager
window for an exit error message.  Take
appropriate action to correct any problem
that occurred.

Verify the port's setup parameters.

Alerts do not arrive at the
management station when there
is a connection to the server;
alerts arrive when there is no
connection.

The Default for a Stop on Failure?
action is Yes.  When the server
already has a connection to the
management station, the script fails
and the alert is not sent.

Insert a Stop on Failure? action with No
as the value in the script before the Send
Alert action.

Be sure that an Answer action displays in
the default.mcr file.



Troubleshooting

109

Problem Explanation Solution

Alerts do not arrive at the
management station when there
is no connection to the server;
alerts arrive when there is a
connection.

The serial port is operating in
originate mode only.

The Port Manager is not executing.

Change the port setting to operate in both
originate and answer modes.

Insert answer in the Macros file.

If you use a script, ensure that the expect
and send dialogs match on both the
management station and the server.

It may help to add \d as the first
command in the Script file for a two-
second delay.  This prevents losing the
management station's initial response(s)
during the time the modem is setting up
the call.

Start the Port Manager if it is not
executing.

A modem does not work if its
power goes off and then on again
after RSM starts.

The controller and the modem may
have different default speed settings.
RSM initializes the modem with the
correct settings when it starts.

Set the modem's defaults to be the same
as the RSM settings. RSM supports the
modem command,
AT&T0E0&C1&D2S0=1&W0 at 38400
bps.  This command initializes the
modem with the correct defaults.  Refer
to your modem documentation for
specific information.

Event monitoring does not catch
very short power surges.

The Event monitor performs its
checking at 5 second intervals.

Most power surges will cause reboots if
they are serious enough and should be
reported by that event.

The server keyboard does not
function.

The management station's
keyboard does not function when
the Console window is the active
window.

The keyboard is not connected to
the controller.

-Or-

The cable between the controller
and the motherboard's keyboard is
not connected.

Check the two cables to ensure that the
connections are correct and secure.

Replace connectors.

Reset the server if the server beeps or
does not function.

Server log entries do not appear
in chronological order.

RSM uses the controller clock.  The
clock has the wrong time or the
server is in a different time zone.

Synchronize the controller clock with the
management station's clock.
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Problem Explanation Solution

The Console window does not
display graphical images that
display on the server.

Graphics modes are not supported.
Graphical output shows up as
blanks in the Console window.  The
Console window supports text mode
only.

Modify server application or disregard
graphical output.

The server cannot access the
management station's diskettes.

To use the Remote Diskettes
feature, the server must be in BIOS
mode and the software must
support BIOS diskette calls.

Use Remote Diskettes feature only when
these conditions exist on the server.

The server does not go into Held
mode.

The Console window and the
Remote Diskettes feature do not
work.

The extended BIOS is not loaded or
it has been corrupted.

Ensure that the EISA Configuration utility
has been run and the controller has a
valid BIOS address.

Transfer the Extended BIOS file from the
management station to the server, reboot,
and then retry.

RSM sends many voltage log
entries and/or alerts when the
server's power is turned off.

Voltage log entries and/or alerts
have been defined for low voltage
readings that normally occur when
the server's power is being turned
off.

Insert a State variable in the Events file
before all voltage monitoring.  Check
whether the Server's Mode is Power Off
and then change the State value so that
RSM does not generate log entries or
alerts when the server's power is turned
off.  Refer to Appendix B, File Examples,
for examples of these files.

MS-DOS hangs when you
transfer an Extended BIOS file to
the server while MS-DOS is
booting.

An Extended BIOS file cannot be
transferred to a server while MS-
DOS is booting.

Wait until MS-DOS has finished booting
before transferring an Extended BIOS file
to the server.

When you transfer an Extended
BIOS file to a server immediately
after resetting it, the message
"Error reading EISA configuration
data.   Download setup failure."
displays.

The address of the Extended BIOS
is unknown because the BIOS did
not complete EISA initialization.

After resetting a server, wait about 30
seconds before transferring an Extended
BIOS file to the server.  This allows time
for the EISA initialization to complete.
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Appendix$
Modems

DIGITAL has tested and verified the following modems with the Remote Server
Manager (RSM):

• AT&T DataPort 14.4 Modem (V.32bis)

• AT&T Paradyne COMSPHERE 3820 SD Modem (V.32turbo)

• Zoom faxMODEM VFX V.32bis

• Hayes Accura 14.4 + FAX 14.4 external FAX Modem

Most Hayes-compatible modems work with the RSM controller.  However,
customization of the dialer strings in the srvm.scr and default.scr files is required.

Refer to your modem documentation for instructions on installing a modem on
your management station.

RSM provides default connection parameters needed in the Connection Actions
pane of the Setup window for these modems.

Multiplexors
The number of simultaneous connections depends on the resources available on
the management station.  These resources include:

• Number of assigned RSM ports

• Number of telephone lines and modems

• Number of lines supported by the multi-line serial communication card
(multiplexor)

• Memory

• CPU speed.
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RSM interoperates with most industry-standard multi-channel serial cards with
full modem control capability (CTS, RTS, DSR, DTR, RI, DCS, and DCD) and
a minimum of 16 bytes of FIFO for line transmitter and receiver.  You can use
any multi-channel cards that have the same characteristics as a NS16550 UART
chip.

DIGITAL has tested and verified the following multiplexors with RSM:

Manufacturer Model
Number

Number
of Lines

Comments

DigiBoard PC/8e 8 Eight-channel intelligent port communication
board for ISA bus.

DigiBoard EPC/X
System

896 Maximum of 64 channels per ISA board using
one or multiple EPC/CON-16 concentrators.

Maximum of 14 concentrators and PORTS
modules.
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Appendix%
Event File Examples

Example1.evt is an example of an Events file. Example1.evt is similar to the
following events file:

EVENT

# This is an example of an Events file.
# It monitors the following sensors:
# Controller initialization (or power up).
# Server reset.
# Server +5V (or power off).
# Monitor server temperature and send an alert if the temperature is outside 40 #
to 104 degrees Fahrenheit.
# Monitor server keyboard for keystrokes.

#State Entry Comparison Value Action1 Action2

#------ ------- -------------- -------- --------- ----------

0 server_mode = = init include=alert_m
s

0 server_mode = = reset log=1 include=alert_ms

0 v_5 outside 47,53 log=10 include=alert_sec

0 temperature outside 40,104 log=20 include=alert_dbl

0 keystrokes > 0 log=60 include=alert_sec
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Macros File Example
Srvm.mcr is a macros file  in your RSM directory.  RSM uses these macros files
to connect a management station to a remote server.  Srvm.mcr is similar to the
following macros file:

MACRO

# This is the Remote Server Manager's Macros file.
# Change as needed to specify your server environment.
# Uncomment the advanced features you want to use.
# Transfer this file to a server as part of setting up a new server
# or whenever the server environment changes.
# (This file specifies an ATT Dataport modem and a speed of 38400.)

connect speed=38400  \
script=att_dp

# Example of how to setup dialback:

#  dialback \
# telephone=99999 \
# include=connect dialback

# Example of how to setup alerts:

# The controller sends an alert to a management station with a port with
# telephone number 99999.
# The port must be specified with Answer as a Port option on the
# management station.
ms1 \

telephone=99999 \
include=connect



Appendix B

115

# Example of how to set up alerts with two telephone numbers:
# This is useful with multiple telephone lines if the first telephone
# number is busy.

ms2 \
telephone=99999 \
include=connect

# Alert Scripts Examples
# ====================

# Example of sending an alert:
# (The server can be connected or not connected to the management station
# at the time the controller sends the alert.)

alert_ms stop_on_success=yes stop_on_failure=no \
alert stop_on_failure=yes stop_on_success=no include=ms1 alert

# Example of sending an alert:
# (The server is not connected to the management station.  If the first
# telephone number is busy (ms1), the controller tries to connect via the
# second telephone number (ms2).)

alert_dbl stop_on_success=yes stop_on_failure=no alert \
stop_on_success=no include=ms1 stop_on_success=yes alert stop_on_success=no
include=md_hup \
stop_on_failure=yes include=ms2  alert
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# Example of sending an alert with a login type of script:
# (See example1.scr file for login script.)

alert_sec stop_on_success=yes stop_on_failure=no alert \
stop_on_failure=yes stop_on_success=no include=ms1 script=login alert

# Example of sending an alert with retries every minute if modem connection
fails:
# (The maximum is specified to be 20 retries.)

alert_retry stop_on_success=yes stop_on_failure=no alert \
stop_on_failure=yes stop_on_success=no retry=20 include=ms1 retry=0 alert

# Example of hanging up Modem:

md_hup hangup pause=5

Scripts File Example
Example1.scr is a Scripts file in your RSM directory.  Example1.scr is similar to
the following Scripts file example:

# NOTE: Most full modem cables have pins 8 and 6 connected to each other at both ends of the
cable.  This will not cause a problem for direct connection.

# Direct connection script: direct "" P_ZERO

# Servers with user name and password security:

login "" P_ZERO ogin:--ogin: user_name word: pass_word

login "" P_ZERO ogin:--ogin: user_name word: pass_word
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Appendix&
Pager Notification Feature

The pager feature allows the server to send a page when an event occurs while the
server’s modem is not in the “CONNECT” state or an Off Hook condition exists.

The Pager setup requires you to modify scripts,  macros, and events to function.
These files are then downloaded to the RSM card.

The event file contains an event that is associated to an action.  When the
condition changes to trigger the action, it calls a macro file that will setup the
Success/Fail conditions for connecting.  This macro file will then call a second
macro file that will set up the RSM port speed to 38400 bps and call a modem
script file to complete the cycle.

The easiest way to test the paging scripts is to associate a system reset to activate
the pager.

NOTE: Using the “ Keystroke > xx" option will only compare the value to the
system keyboard buffer count 1 time until the system is reset and the
system keyboard buffer is cleared.

Setting up the pager

1. Select "Options" from the Toolbar.

2. Select Script from the Options drop-down menu.

3. Select Open from Script drop-down menu.

4. Select “xxxFilex.SCR”.
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NOTE: When testing, it is advisable to save the srvm.scr, srvm.mcr, and srvm.evt
files to other files to prevent losing all current attribute settings. Upon
successful testing, you may rename the files back and download if you so
desire.

If you are not sure of the name of the current file:

1. Select Functions from the toolbar

2. Select Transfers to/from from the Functions pull-down menu.  The screen that
displays will show the names of the currently downloaded files on the server.

3. Identify the modem script and copy the attributes to a new script named for
example [pager]. Keep the name lower case to avoid confusion.  In the pager
modem script, change the following values:

− <TIMEOUT  90>

− Delete the second TIMEOUT entry

− Change the last Expect from CONNECT to BUSY  <EXPECT
BUSY>

Another way to create this macro is to edit the xxxx.SCR file, which is located in
the RS_MGR directory, then copying and pasting the modem lines.

Review the following Pager setup example, substituting your filenames for the
scripts and macros.

 Pager Setup Screens Examples
The following shows how the appropriate screens will display when setting up the
pager feature.  Modifications will be made to events, macros and scripts.  The last
step is to download the files to the RSM board.  The event will be a [System
Reset].  The reset will trigger an event in the event file that will call the [alert_ms]
macro.
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The [alert_ms] macro sets up the success / fail procedure options, sends an alert
to the Management station, and calls a second macro [ms1].

In turn, the [ms1] macro sets the Pager telephone number, and calls a new macro
[skypage].

The [skypage] macro sets the RSM port speed to 38400 and calls the new
modified modem script [pager]

The [pager] script sends the dialer string to the modem for connection and
message transfer.  It then identifies an event for paging and assigns one action.  It
finally calls the alert_ms macro.
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Selecting Server Mode - Reset, as shown in the following Event Definition screen,
will trigger the event to send a page.  This screen also assigns the action of calling
the [alert_ms] macro.
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The following screen sets up the Success/Fail options and then calls a second
macro, [ms1], prior to sending an alert.



RSM User’s Guide

122

The following screen shows macro [ms1].  It sets up the pager telephone number
and message as well as the call to the Skypage macro.
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Two actions are assigned on the following screen:

• Speed 38400 (This speed should be used regardless of the modem speed)

• Call to the Pager macro file
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The following screens show the attributes for the Modem Script (Zoom).  Select
the modem script name, Pager, and copy the attributes from the Zoom macro file
from this screen.
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The following screen shows the attributes for the modem script Pager copied from
the modem script Zoom.  The script requires that when the modem sends the
telephone number string, it will expect a “Busy” response from the modem.  If the
default modem string is used, the modem waits for “connect,” which is never
received.  It then waits to timeout, and then redials.

From this screen, download the following files:

xxxx.EVT

xxxx.MCR

xxxx.SCR

Once the files have successfully downloaded, disconnect the server and test for
paging.
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Dialback Security Feature
The dialback security feature allows the server, upon connection from the
Management Console, to hang up and dial back to the Management Console's
modem.  The server does this by reviewing a macro file downloaded to the RSM
controller board.  If a "dialback" macro already exists, the feature is enabled.

The dialback feature is set up by first identifying that the RS_PM.INI file has the
[a] option in the command line for the COM port.  To do this:

1. Open the RS_PM.ini file.

2. Check for the following:

[Ports]
com1=zoom:oa

where:

o= Originate

a= Answer

Setting up the Dialback feature

1. Check the modem script file name in the modem script.  Select “Options" from
the Toolbar, then select “Script” “Open” “xxxFilex.SCR”.

NOTE: If you are not sure of the name of the current file:
1. Select Functions from the Toolbar.
2. Select Transfers To/From.  The screen that displays will

show  the currently downloaded files on the server.

The macro file will later be downloaded to the RSM board after the additional
values are edited.

2. Type "A" and press Enter.

3.  Open the script file by selecting “Options” “Script”  “Open” “xxxFilex.SCR”.

4. Identify the modem type by selecting:

     [Cancel]
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5. Type “B" and press Enter.

6. Open the Macro file by selecting  “Options”  “Macro”  “Open”
“xxxFilex.MCR”.

7. Type "B1" and press Enter.

8. Create a new macro labeled "connect2" [Any file name].

9. Assign the following two actions to the macro from the macro screen:

Speed  38400  ( This speed should be used regardless of the 
 Modem Speed)

Script (Modem script from Step "A" )

NOTE: Use the default macro ("connect") if the script has the correct settings.

10. Type "B2" and press Enter.

11. Create a new macro labeled "dialback" (label it lower case)

12. Assign the following three actions to the “dialback” macro from the macro
screen:

Telephone ####

Include   connect2 (File name from "B1")

dialback  [ No Value ]

13. Select [SAVE] from the File menu.

14. Type "C" and press Enter.

15. Connect to the Server.

16. Type "C1" and pres Enter.

17. Download the xxxx.MCR file.

18. Disconnect the server.

19. Type "D" and pres Enter.

20. Reconnect to the server and and select Test.
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Index

-- A --
Actions, event definition

table, 88
Actions, macro definition

table, 94
Adding and changing

event definitions, 81
macro names, 91
script definitions, 96
scripts, 98

Adding servers, 23
Select window, 29

Alert heading
Server Directory pane, 22

Alerts
defined, 3
display on Status window, 37
receiving and removing

Port Manager window, 46
Alt/Esc
Alt/Esc option

Reset/Keysdialog box, 51
Another Setup pane

Select window, 29
Ascending

Options menu, 72
At Management Station mode

Remote Diskette feature, 61
At Management Station Read only mode

Remote Diskette feature, 61
AT&T DataPort modem

tested for Remote Server Manager, 111
AT&T Paradyne COMSPHERE modem

tested for Remote Server Manager, 111

-- B --
BIOS file

Controller Extended BIOS, 57
BIOS mode

required to use Remote Diskette feature,
59

Booting server, 51

-- C --
Cascade command

Window menu, 73
Change the working directory

Specifying Directories, 10
Clocks

setting and synchronizing, 54
Close All command

Window menu, 73
Close Server command

Window menu, 73
CMOS setup file

CMOS configuration data, 57
Cold boot option

Reset/Keysdialog box, 51
Configuration files. See also Files

defining default file names, 27
Confirm All Deletions option

Options menu, 76
Connect on Open Control option

Preferences window, 76
Connect/Disconnect command

Functions menu, 70
Connection actions

entering, 27
table, 26
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Connection Actions pane
Setup window, 25

Connection status
Control window, 35

Console button
Control window, 62

Console window
function of, 19
monitoring server console, 61

Control menu
commands, table, 68
using, 67

Control window
Connection Status pane, 35
Console button, 62
Disconnect button, 47
function of, 19
Power off/Power on button, 50
Power off/Power on dialog box,
example, 50
Reset/Keys button, 52
Set Clock button, 55
Transfers button, 58

Controller, on server
installing, 9

Conventions
Remote Server Manager menu bar, 67

Copy command
Edit menu, 69

Cut command
Edit menu, 69

-- D --
Default file names, 56
Default File Names for Transfers pane

Setup window, 27, 58
Defining

events and event actions, 81
macro actions, 92
script steps, 99
sensor parameters, 83

Delete command
Edit menu, 69

Deleting a Server
Using the Server Filter Option, 33

Descending
Options menu, 72

Description heading
Server Directory pane, 22

Dial-back security, 4
Disabled mode

Remote Diskette feature, 61
Disconnect on Control Close option

Preferences window, 76
Disconnecting from a server, 47
Diskette image file

functions of, 59
Diskettes, remote

functions of, 59
Displaying servers, 31

-- E --
Edit menu

commands, table, 69
commands, table, 69

Edit Setup command
Functions menu, 70

EISA configuration file
configuration memory, 57

Enabling the Filter Option
Using the Server Filter Option, 33

Entering connection information, 27
Entering user names

Security Definitions window, 103
Environment Sensors pane

Status window, 39
Errors, 107–10

connection, 108
finding Online Help, 107
out of disk space, 107
startup, 107

Event definitions
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adding and changing files, 81
inserting, deleting, and reordering, 89

Event Definitions window
function of, 20

Event Tests, 85
Events

defined, 3
defining, 81

Events command
Options menu, 71

Events files
event definitions and responses, 57
example, 111, 113, 117
function of, 80
saving, 90

Exit command
File menu, 68

Exiting Remote Server Manager, 31
Export command

File menu, 68
writing server status, 42

-- F --
File menu

commands, table, 68
commands, table, 68

Files
configuration files, using, 79–106
names, default, 56
transferable, table, 56
transferring to/from server, 56

Firmware file
controller firmware, 57

Functions menu
commands, table, 69
Disconnect command, 47

-- G --
Get Options command

Window menu, 73

Get Select command
Window menu, 73

Global Accelerator Commands on
Preferences window, 77

-- H --
Hardware and Software Requirements

Remote Server Manager, 6
Hayes ACCURA 144 modem

tested for Remote Server Manager, 111
Hayes-compatible modems, 111
Held mode

releasing server from, 52
Help, online

errors, 107
Hold on Boot check box

Control window, 52
Holding server

during power on and boot, 52

-- I --
Icons

Remote Server Management console
Program Manager window, 10

Include, serial communications
connection action, 26

Inserting and deleting
macros, 92
scripts, 98

Inserting, deleting, and reordering
event definitions, 89
macro actions, 94
script steps, 100
user names, 104

Installation
controller in server, 9
modem, 8
multiplexor, 9

Intel 486 or Pentium PC
required for Server Manager, 6
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-- K --
Keeping a Server

Using the Server Filter Option, 33
Keyboard status

values for, table, 42
Keystroke log file

characters typed since last reset, 57

-- L --
Last Contact heading

Server Directory pane, 22
Log entries

Status window, 37
using in other applications, 39

Log files
servers, 106

Log upload error message, 42

-- M --
Macro actions

defining, 92
inserting, deleting, and reordering, 94

Macro Definitions window
adding or changing Macro definitions,
90
function of, 20
Macro Name pane, 91

Macro Name pane
Macro Definitions window, 91

Macros
files, creating and editing, 90
files, saving, 95
inserting and deleting, 92
names, adding and changing, 91

Macros command
Options menu, 71

Macros file
editing, 90

Macros files
defining events and actions, 57

example, 114
Management console

software, starting, 13
Management station

minimum requirements, 6
remote console, 61

Maximize command
Control menu, 68

Memory
defining default file names for transfers,
27
transferring to/from server, 56

Menu bar
conventions, 67
Remote Server Manager

commands and functions, 67–78
Minimize command

Control menu, 68
Modems

installing, 8, 9
tested for Remote Server Manager, 111

Monitor
recommended type, 19

Monitoring server status, 36
Move command

Control menu, 68
Multiplexors

installing, 9
tested for Remote Server Manager, 111

Multiplexors tested for Remote Server
Manager table, 112

-- N --
Newline -> Tab option

Preferences window, 76
Normal mode

Remote Diskette feature, 61

-- O --
Open Console command
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Functions menu, 70
Open Console on Connect option

Preferences window, 76
Optional Remote Server Manager
Products, 6
Options menu

commands, 70
Scripts command, 96

Out-of-disk-space error, 107

-- P --
Paste command

Edit menu, 69
Port Manager window

receiving and removing alerts, 46
Ports, serial communications

connection action, 26
Power off button

Control window, 50
Power off/Power on

button, Control window, 50
command, Functions menu, 70
dialog boxes

Control window, example, 50
Preferences command

Options menu, 71, 74
Preferences dialog box

function of, 20
Preferences file, 106

used at startup, 106
Preferences window options

table, 76
Print commands

File menu
printing status information, 42

-- R --
Read only mode

Remote Diskette feature, 61
Release button

Control window, 50
Release command

Functions menu, 70
Releasing server from Held mode, 52
Remote console

using management station as, 4, 61
Remote Server  Manager

configuration files, using, 79–106
Remote Server Management console icon

Program Manager window, 10
Remote Server Management Station
Software, 1
Remote Server Manager

exiting, 31
menu bar, commands and functions,
67–78
menu bar, conventions, 67
software, starting, 13
solution, 1

Remote Server Manager controller
See Controller, 9

Remote servers. See Servers
Remove command

Functions menu, 45, 70
Removing servers

Remove command, Functions menu, 45
Reset firmware option

Reset/Keysdialog box, 51
Reset option

Reset/Keys dialog box, 51
Reset/Keys

button
Control window, 52

Reset/Keys button
Control window, 50

Reset/Keys command
Functions menu, 70

Reset/Keys dialog box
options, 51

Reset/KEYSdialog box
Hold on Boot check box, 52

Resetting server, 51
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Restore command
Control menu, 68

Retry, serial communications
connection action, 26

-- S --
Save As command

File menu, 68
Save Windows Layout option

Preferences window, 76
Saving

Events files, 90
Macros files, 95
Scripts files, 101

Saving server information, 28
Script Definitions window

example, 97
function of, 20
Options menu, 96

Script Name pane, 98
Scripts

adding and changing, 98
command, Options menu, 72
connection action, 26
defining steps, 99
files, communication scripts, 57
files, saving, 101
inserting and deleting, 98
inserting, deleting and reordering steps,
100
steps and values

table, 100
Scripts Files, 96

examples, 116
Security

command, Options menu, 72
dial-back, 4
files

creating and editing, 101
user-defined security, 57

user

defining, 101
Windows NT, 3

Security Definitions window
function of, 20

Select All command
Edit menu, 69

Select window
function of, 19
Options menu

display and options, 31
selecting a server, 21
server information displayed, 20

Selecting a server, 21
Sensors

events and, 81
parameters

defining, 83
table, 85

Server Attribute Names
inserting and deleting, 75

Server heading
Server Directory pane, 22

Server Mode
values for, table, 41

Server System Status pane
Status window, 40

Servers
adding, 23, 29
attribute names

Preferences window, 75
booting, 51
defining multiple, 29
deletion confirmation

Preferences window, 76
disconnecting from, 47
display options, 31
files, 106
filtering options, 31
holding during power on and boot, 52
information displayed in Select Window,
20
log entries, 37
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log files, 106
overview of remote management, 1
releasing from Held mode, 52
removing, 45
resetting, 51
saving information, 28
selecting from Select window, 21
Setting the EBIOS Address, 53
system status, 40

Session names heading
Server Directory pane, 22

Set Clock button
Control window, 50, 55

Set Clock command
Functions menu, 70

Set diskette button
Control window, 50, 59

Set Diskette command
Functions menu, 70

Set EBIOS Addr option
Reset/Keys dialog box, 51

Setting controller or server clock, 54
Setting the EBIOS Address, 53
Setup New command

Select window, 70
Select window, Functions menu, 24

Setup window
Connection Actions pane, 25
Default File Names for Transfers pane,
27
Defaults for Transfers pane, 58
example, 24
function of, 19

Setup, Remote Server Manager
adding servers, 23

Show Control command
Functions menu, 70

Size command
Control menu, 68

Software
Remote Server Management Station, 1

Sort by Alert Pending

Options menu, 72
Sort by Connect Time

Options menu, 72
Sort by Last Contact

Options menu, 72
Sort by Name

Options menu, 72
Speed (baud rate)

connection action, 26
Starting management console, 13
Startup errors, 107
Status reports

writing or printing, 42
Status window

Environment Sensors pane, 39
example, 37
function of, 19
monitoring server status, 36
Server System Status pane, 40
update button, 42

Synchronizing clocks, 54

-- T --
Remote Diskettes mode, 61
Telephone, serial communications

connection action, 26
Temperature

monitoring, 39
Temperature Scale

Preferences window, 76
Terminology

Remote Server Manager, ix
Testing

events
symbols for comparisons

table, 86

Tile command
Window menu, 73

Tile Server command
Window menu, 73
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Transfer button
Control window, 50

Transfer to/from command
Functions menu, 70

Transfers
controller files, 30
files and memory, 27
server files and memory, 56

Transfers button
Control window, 58

Transfers window
function of, 19

Troubleshooting, 107–10
tips, table, 108

-- U --
Update Status command

Function menu, 70
updating server status, 42
User names

entering in Security Definitions window,
103
Security Definitions window

inserting, deleting, and reordering, 104
Users

security
defining, 101

specifying preferences, 74

-- V --
VGA Console command

Functions menu, 70
VGA frame buffer

and remote console feature, 62
View Status command

Function menu, 70
Voltage

monitoring, 39

-- W --
Warm boot option

Reset/Keys dialog box, 51
Window List command

Window menu, 73
Window menu

active window, changing, 45
Windows

active window, changing, 45
Console

function of, 19
monitoring server console, 61

Control
Connection Status pane, 35
function of, 19

Event Definitions
function of, 20

functions, table, 19, 20
Macro Definitions

function of, 20
Script Definitions

example, 97
function of, 20

Security Definitions
function of, 20

Select, 21
filter option, 31
function of, 19

Setup
example, 24

size and arrangement, 19
Status

example, 37
function of, 19
monitoring server status, 36

Transfers
function of, 19

Windows menu
commands, 72
commands, table, 73

Windows NT
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security, 3
version required for Server Manager, 6

-- Z --
Zoom modem

tested for Remote Server Manager, 111
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